[BUG] RX7 Connect Clip Offset

There is an annoying bug when you use Izotope RX7 Connect with multiple clips. The first clips align properly but the more clips you have the more they get shifted in time for some reason. This happens in both Nuendo 10.2 and the new 10.3.

Hi,

Could you attach a screenshot or make a short video screen recording, please?

Hey Martin,

Sorry for the late respoen but I didn’t get a notification that someone replied.

Here is a short videoclip showing the issue: https://youtu.be/ELy67RcDuCY

Thanks!

Melvin,

It looks as if you’re not letting it finish the render to clips before you click / deselect / reselect. I’m wondering if you get the same result if you allow it to complete before you do anything else?

(What I mean is that it reads that it’s processing clip 30/39 when you click outside of the events and thus deselect them)

I posted about this issue a while back as well. Didn’t find a solution. I render multiple clips as a single clip now and process that instead. :frowning: Multi-clip DOP results in timing offsets unfortunately.

Mattias,

Good point but I usually just let it render without touching anything with the same results.

@Splaaat
Yeah I tried bouncing one long audiofiles but that takes ages.
I opened a support ticket with Steinberg and also with Izotope so I hope they will respond soon.

So I just tried this by copy-pasting a set of events onto two tracks and processing one, so the other functioned as a reference. It worked every time except if I ran the RX function twice on the same events. Then the timing got shifted significantly. And it didn’t matter if I used DeNoise twice or different modules within RX.

So, did you round-trip the audio more than once?

If so the solution (other than not doing that) is to make sure your edits are good and then ‘bounce’ the events into one new piece of audio before processing. Not ideal of course.

You could also of course choose to do only some processing in RX and leave the rest on inserts. Also possibly not ideal.

Yeah this might be the problem with RX Connect, because you need to apply it once, to send it to the RX editor, then send it back to cubase from RX and apply once more. The offset happens on applying the second time. So it seems to bug in Nuendo.

The workarounds you mentioned do work, but are a pain. I hope they fix this soon.

I wonder if this is a deeper problem. I can’t recall right now but I do think that in Pro Tools any change to a clip results in new audio files with unique names. If that’s somehow not the case in Nuendo because of how naming and file management conventions are structured then the solution might be very difficult to find. I mean, imagine if it’s something related to how events relate to audio files and also naming, then any “fix” on Steinberg’s end would have to involve redesigning how all of that works. And because that’s so very fundamental to everything we do inside of Nuendo an error would be absolutely terrible.

As things stand now it’s a nuisance to have to consolidate events to get work done, but at most it takes me about 2 seconds to do before getting to RX Connect for transfer. The possibility of problems linking events to audio files on disk is just… infinitely worse.

Of course I’m speculating, but something tells me there isn’t a simple solution to this and unfortunately neither company seems to spell out the technical problems.

Well it has to do with recent changes because it was working perfectly fine in Cubase 10 and Nuendo 8. I’ll post an update if I hear back from Izotope or Steinberg. But for now I’ll bounce long files and just have to be more patient. Thanks for the help Mattias!

I’m 99% sure I had similar issues in Nuendo v8.x.