BUG: solo applied only once on 2 presses

Preferences used:

    1. Open the Empty template
    1. Add 10 MIDI or AUDIO tracks
    1. Hit S on the keyboard
    1. Hit UP or DOWN on the keyboard. Result: the selected track is not soloed although it should be. It’s still muted.
    1. Hit UP or DOWN again. Result: now the selected track is soloed and muted all the other tracks which is the desired behavior.
    1. Hit UP or DOWN again. The selected track is not soloed.

And so on…
EDIT: same thing happens with the mouse instead of hitting S on the keyboard.

Here is a video representation of this bug: https://youtu.be/SSeM1vw4zco

Cubase 11.0.10 Build 321
Windows 10 Pro 64bits version 20H2 OS 10.0.19042 Build 19042
CPU: AMD Ryzen 9 3900XT 3.8Ghz
RAM: 4x16GB of DDR4 Crucial Ballistix Desktop Gaming Memory Kit, red @ 1600MHz
GPU: Gigabyte GTX N970IX OC-4GD
SSD for Win10 + Cubase: Samsung SSD 970 EVO Plus 1TB Nvme M.2
SSD: Samsung SSD 860 EVO 4 To SATA3
PSU: Corsair 750W Gold tier1 on LTT
Case: Be Quiet Pure Base 500DX

Who can reproduce and confirm this bug?

I followed all your steps and it’s all working fine here. All selected MIDI tracks are soloed when selected, both through arrows or mouse clicking. I’m on Win10, and latest Cubase version.

Thanks, I guess you used the same Preferences settings as in the video?

Oh, my bad! I just did the test again, reproducing your exact preferences settings and got the same issue as you described. It’s like alternating the solo feature each time we switch a track, by clicking or using arrow keys.
I could narrow the conflict possibilities and ended up with the only two preferences in the Project & MixConsole tab that are causing the problem. If you just check “Select Channel/Track on Solo” and “Enable Solo on Selected Track” the problem occurs.
Also, it’s not restricted to MIDI tracks. It happens to any type.

Thanks for testing and confirming this, you saved me some time as I was about to scrap all my Cubase install.

From my tests it seems that it’s just a graphic bug, because despite the track being displayed as muted, it’s actually being soloed and play the correct audio.

Can you also confirm this?

I tested it again and it’s not just graphical, it’s a functional bug. I created a couple of Instrument tracks with Halion. Created a MIDI note in each one, put them in a loop and monitored the level bars while selecting different tracks. Those that are not solo activated due to the bug don’t have any sound.
I checked the only two problematic preferences I mentioned above.

You’re right, I tried in a blank project and recorded different parts. The bug is indeed not just graphical like I was stating in my previous message. Oddly it was just graphical when I tested on a project which was ported from C6 which may explains why it behaved differently in my other test.

I hope Steinberg will correct this quickly because this bug for a such basic functionality is a pain to work with…

Any chance you could reply in this format?

Sure I’m going to do that.

Any news on this issue?
And this one? BUG: Preferences setting Select Channel/Track on Solo not working for the Project window - Cubase - Steinberg Forums