Bug: SpectraLayers One 7 - Hard PC reboot after "Unmix Vocals"

Regardless, I ran the standalone SL program with the Open GL enabled and tried to unmix the vocals on a track and I got the crash/reboot all the same.

Hello Robin,
I gave it a shot with the sde.exe
sde.exe quits after ca. 10s. It doesn’t start SpectraLayers. This is true for all 3 variants you mentioned above.
I see the spectralayers.exe showing up in the taskmanager.
I get this in the log for starts with the sde:
22:50:07.832 1c6c INFO C:\Program Files\Steinberg\SpectraLayers 7\Win64\SpectraLayers.exe
22:50:07.868 1c6c INFO auto-detected folder: C:\Program Files\Steinberg\SpectraLayers 7\Win64
22:50:07.908 1c6c INFO opengl rendering (settings)
22:50:07.911 1c6c INFO early init done
22:50:07.942 1c6c INFO creating app…
22:50:08.903 1c6c INFO loading properties…

You can get a log from a normal start here to get my system specs:
https://www.steinberg.net/forums/viewtopic.php?f=305&t=202363

Hi MarcoE, indeed eLicenser conflicts with the -nhm and -pnr mode and prevent SL from launching. However -snb mode should work, can you let me know what happens ?

sde.exe -snb -- "C:\Program Files\Steinberg\SpectraLayers 7\Win64\SpectraLayers.exe"

Also, I would be interested if you could video capture (with a smartphone for instance) when and how the crash/reboot happen. There might be some clue in the details of events.

-snb doesn’t work. same result. no start, see previous log.
Here is the video:

You can also PM me a debug build with more detailed logs.

What’s the sample rate of your audio file ? (VoxRef 3.wav)
Looking at the frequency scale it seems to be 22050 Hz (but maybe it was zoomed).

If it was a file sampled at 22050Hz, does it happen with a file sampled at 44100Hz as well ?

Someone elses computer having full hard PC reboot but it doesn’t seem related to SL.





also, has anyone here tried running Cubase in safe more? I see this is happening in standalone though so probably wouldn’t help

The sample in my video is a 32bit wav @44.1kHz created with Cubase render in place.
I tried with several files. All crashed my system.

Like a fool I’ve just bought the full SepctraLayers Pro 7 program and the problem is the same. I am really not impressed.

Hi Tech-dance, assuming your system has the correct specs required (Open Gl 3.0, etc), and seeing you have already sent your log files to Robin, you seem to have followed most guidelines here.

However, it might help you to know - since I’ve read you have a Radeon GPU - that in my case, I tried many different ways to overcome stringent SL 7 GPU functionality requirements. Several AMD, including Betas and open source drivers didn’t help. All kinds of configuration selections neither (tried them all). The same with diverse installation/uninstall sequences.
Until …out of the dark, applying an automated driver update-fix with the “Driver Booster” application (that I got from GiveAwayOfTheDay timed freebies)… SL 7 started functioning in full flight.

///My conclusion is that there are Driver related limited functions probably occurring at the registry, which are not easy to fix/overcome. Note that I use an oldish AMD eGPU (tried two models with identical results).

Tried with Adrenalin 18.9.3 and very latest 20.9.1, it did not make any difference. Otherwise, the specs from my opening post of this thread are still unchanged.

Robin: Any other thing I can do to help you find the reason?

Undaunted by death. :mrgreen:

Let’s hope for a fix.

I know this is a long shot, but did you guys try the 7.021 update? It fixed an unrelated problem I was having, one that wasn’t listed in the official log.

Care to detail your issue?

You can read about it in the ‘Announcements’ thread.

It’s the same binary application - so issues you’re having in One will likely be the same in Pro. There’s also a 30 days trial version of Pro.
We’re working on this issue, but please understand it’s quite a complex one that needs time, as only a few computers show it right now and we were not able to repro it on any of our computers here so far.

Same happens here but not every time.
Only happens about 1 time in 5 when any sort of unmix stems is used.
Hard machine reset.

Hippo

Exact same problem, both in standalone and as a Cubase extension. Goes to BSOD and reboot.

I’m on Windows 10 1909.

Additionally, I’ve found that following the crash my system becomes entirely unstable, the audio interface drivers are corrupted and I get repeated BSODs with IRQL NOT LESS OR EQUAL and SYSTEM SERVICE EXCEPTION errors. Restoring the system drive from a backup has fixed things for now, at least. I guess I won’t be using SpectraLayers 7 until this issue is addressed.

I’ve tried and tried with this, but now given up.

I’ve been a loyal customer of Steinberg for well over 3 Decades

Just bought iZotope standard
For me it works better in the every day audio uses that I could put spectral layers to.

This is software that seems to have no home, a bit like the hovercraft, Brilliant idea , worked, but had little application in real life.
(We all drive to work in one, cross oceans in one , we could but we don’t)

Just turn things around for a minute imagine selling an audio app to edit video

It maybe “creative” and a great art concept but a professional photography every day tool ???

Just my opinion

Hippo

Ok. I have no way to see if this is related, but since the bug seems resistant to diagnose I will describe here one of the things I tried in order to fix my SL 7 issue, apart from what was mentioned here. Since at that point there was no visible way out, i went for the unusual, extravagant measures:
did a cleaning of “unplugged device data” together with a reprogram/clean of assigned IRQs…

Since only tested OK SL 7 after applying all those additional actions, I don’t really know exactly what indeed fixed things… That IRQL and corrupted audio interface drivers mention you posted today djangodeadman, brought my IRQ cleaning to memory.