BUG: Spectralayers record function bugs out

When recording audio directly into Spectralayers 10.0.10, upon trying to play back the audio, the FFT display and the audio is blanked out as it scrolls through. The record button seems to be latched to the play button, so it’s impossible to play back recorded audio without saving, closing Spectralayers, re-opening the program, then re-opening the audio file and pressing play.

Steps to reproduce:

  1. Open Spectralayers
  2. Choose the audio input you want in Preferences
  3. Create a new file
  4. Press record to record the audio source
  5. Press stop to stop recording
  6. Press play or press space bar to start playback.

As the locator moves across the audio, it blanks it out on the FFT. It also wipes the audio away. You’ll notice the record button is still red when using the play button.

Windows 10 Pro (1904)
Spectralayers 10.0.10
SSL2+ (used for recording)

Just found this out. The locator has to be moved to precisely the start of the file before playback commences normally. The record button will stop latching and will not overwrite the audio with silence when doing this.

@jim_griff I wasn’t able to repro the issue at all… Would you be able to provide a video recording of the issue ?

Hi Robin. Sure, here’s a screen recording of the issue, as well as the workaround (moving the locator to the beginning to “unlatch” record mode).

EDIT: Just found out, scrubbing using the locator will also “unlatch” record button and allow normal playback.

Cheers, Jim.

1 Like

Thanks for the video, it showed me the one element I was missing to repro : the playhead has “Return to Start on Stop” disabled. When this option is enabled (the default), the issue doesn’t happen.

Thanks Robin.

I’ve enabled “Return to start position on stop” but the problem persists. I still need to scrub in order to prevent the record button from becoming latched on.

I just found that when Scrubbing is disabled, it works as intended. When it’s enabled, it causes the glitch unless I scrub a certain amount after stopping recording.

@jim_griff can you tell me if this installer fix the issue?

Hi Robin,

Yes, it fixes the issue, but it introduces another issue where after creating a new file the start position is (see image).

I have to move the locator manually to 0:00:00.000 to start recording in the main view, otherwise there’s nothing there to play back.

In addition, after being able to record some audio after moving the locator into the window, when using the unmix feature all audio disappears. Even undoing doesn’t make the audio reappear. The unmix feature works fine on audio files that are opened from the hard disk.

@jim_griff Please give this new installer a try, it should fix both issues you reported.

1 Like

Spot on. Works a treat! Thanks so much Robin. :+1: