[BUG] Still, in 2018, Generic Remote is not processing NRPN

Hi guys,

I know this is not new, but we are now in 2018, so it’s time to take it back.

I’ve been trying to use NRPNs with my MIDI controller. I’ve tried everything. I’ve done a BIG research, but it does not work.

Generic Remote is probably one of the top and uniques Cubase’s features that SB has been abandoned from years ago.

If anybody knows better than me, please, don’t be shy.

If some in SB reads this forum, please, add this to your very confirmed and vintage bugs and feature request.

Thanks!

Best,

Antonio.

Hi,

I wouldn’t consider this as a bug. I would say it’s specified like this. It’s more complicated with RPNs and NRPNs. Cubase would take care about 14 bit messages. So you would always need to send NRPR MSB, LSB and value. Does it really makes sense?

Thanks for answering!

Could you elaborate this? Is there a way then?

This is very interesting and very geeky. :wink: I don’t have an answer for you, but I want to understand the question.

Are you saying have a controller that sends nrpn commands, and you want the generic remote to use them? What function would they perform? What device is sending the data?

I read this page, so I understand the anatomy of the nrpn and rpn messages, but it seems that their use is limited to devices that are specifically designed to use them. Like what this guy is saying:

https://psrtutorial.com/music/articles/howToNRPN.html

I would like to control the selected channel Volume, using an external controller, sending and receiving NRPNs. The controller can send CC 14 bits too.

The controller is a MCU device, but it’s been processed by Bome’s MIDI Translator.

Thanks :slight_smile:

What data exactly does it send, please?

I was trying to control volumen with a fader sending NRPN

In fact, I fixed it editing the XML directly and re-importing it :slight_smile:

So what data does Cubase receive?

What did you type to the XML?

(I guess we’ll never know :frowning: :wink:)

Hello, the original poster probably found the old solution which was based on manually editing the Generic Remote XML file:
http://dejongh.dk/wiki/doku.php?id=cubase:control_automation_with_midi_cc#how_to_use_14bit_cc_in_remote_controls

This solution was originally published by me on the old Steinberg forum.

Indeed, it’s a bug. Generic Remote actually can receive 14bit messages. However, it’s not possible to configure this functionality via Cubase GUI.

Best regards

Miloslav

Brilliant. Thank you Miloslav. I will post it below, hope that’s okay with you.

From http://dejongh.dk/wiki/doku.php?id=cubase:control_automation_with_midi_cc#how_to_use_14bit_cc_in_remote_controls

How to use 14bit CC in Remote Controls
There is, indeed, a bug in Cubase which affects the 14bit NRPN messages on the receive side, however, this bug rests in the Generic Remote GUI rather than in the underlying control functionality. For a workaround, open the Generic Remote setup XML file, find the corresponding CTRL item in the CTRLTABLE section, and add 16 to the value of the FLAGS attribute. This is the trick which makes the 14bit NRPN messages being received properly. The Generic Remote GUI sometimes does not write the correct value of the FLAGS attribute into the XML setup file.

An example: If I set “Fader 1” to NRPN-Ctrl with the “R” (Receive) tag and the maximum value of 16383 then the corresponding item in the XML file looks like that:

<ctrl> 
  <name>Fader 1</name> 
  <stat>2</stat> 
  <chan>0</chan> 
  <addr>1234</addr> 
  <max>16383</max> 
  <flags>1</flags> 
</ctrl>

Now, when I change the FLAGS value from 1 to 17 (1+16) and reimport the file into Generic Remote then Cubase starts responding to the incoming 14bit messages correctly! What a magic!

Of course, it’s okay. Thanks, Steve!

Miloslav

Hey!

The described tip did not work to me.


What I do is:

  1. Select NRPN as option and the max range (16383) in the Generic Remote editor. It DOES NOT work, but do it anyway. You can set the flags in the way you want now.
  2. Export (save) the Generic Remote configuration. If you don’t do it, Cubase forgets the settings. Yes, another bug :nerd:
    I use to close Cubase. It does not matter, but it’s safer.
  3. Open the xml file with any editor. In mac, I use Adobe’s free Brackets.
  4. Look for the NRPN line and change the stats

from 176 to 2

:

<ctrl><name>HF Gain</name><stat>176</stat><chan>0</chan><addr>0</addr><max>16383</max><flags>3</flags></ctrl>

to

<ctrl><name>HF Gain</name><stat>2</stat><chan>0</chan><addr>0</addr><max>16383</max><flags>3</flags></ctrl>
  1. Reopen Cubase, reimport the xml and it works.

Further geeky thoughts:

  • As long as I’ve been researching Cubase is completely based on XML. Everything in Cubase is set with XML files
  • I’m sure there are hidden features in Generic Remote. I’ve try to find some with no luck

I hope this helps someone.

Hello, Antonio,

yes, your target control may work, but are you sure that it is really operating with 14-bit precision? Try to change the FLAGS attribute as well:

<flags>3</flags>

to

<flags>19</flags>


Miloslav

It does work in 14 bits with no change in the flags. In fact, I had to change the resolution in the controller due it was too slow.