Bug:Tempo Track automation incredibly slow

Apologies if this has already been addressed. I didn’t find anything in a search.

Windows 7 Ultimate SP1
M-Audio Firewire 410

Automating the tempo track when there are time-dependent audio events produces a major lag. When inserting points on the tempo track, there’s a 10-15 second delay.

Step 1: Create audio track
Step 2: Import something long-ish like a full song and place it on Track 1
Step 3: Check “musical-mode” on the song in the pool
Step 4: ctrl+T and draw tempo track automation - Doing this should produce a significant lag

This may or may not get worse depending on how many warped tracks there are in the project.

Probably not a bug. Continuously changing tempo on a musical mode track is sure to bog a processor down. What processor are you using? How dense is the tempo curve?

Core2Duo e6400 (2.13GHz)

It’s on the lower end, but the lag still seems abnormal. It also chokes when editing warped audio events during a tempotrack ramp (changing volume, adjusting size, etc).

In the preferences, I have my Timestretch tool algorithm set to Realtime - does this apply to warped audio events?

If your CPU is faster, see what the lag is like for you…

I tried a sine wave tempo curve on a single audio track in musical mode and I had no lag or pops. The processor usage was significantly higher than without musical mode, however. To be honest, I was quite impressed with the results. I have never “warped” audio much. The file I used was just some guitar chords strumming. I could hear the artifacts when the tempo got to extremes, but it kept time very well.

Well dang. Me: 0, Technology: 1. I guess I’d better upgrade.

Did you really have no hiccup whatsoever? Any small lag at all? Did it take a moment to think? Mine literally is unresponsive for about 10 seconds after messing with it. If yours was fine, I’ll make sure to have an i7 within the year.

It’s the ‘elastique pro’ algorithm that’s bringing it to its knees. I changed all the audio events to ‘elastique efficient - time’, but it’s not much better. Even with my average speed CPU, it’s pretty unusable.

I’ve switched to ‘standard - mix’ for editing… seems to be workable.

I will say, however, the ‘elastique pro - time’ sounds fantastique. Too bad I can’t use it while working.