BUG : Toggling Musical Mode causes Lower Zone Editor tabs to close when Snap Point isn't at Start


There is a issue with the Lower Zone Editor, where enabling Musical Mode when the Snap Point isn’t at the Event Start causes some of the opened tabs of the Editor to close.

Prerequisites :

  • The Audio Clip tempo (in the Pool) needs to be different than the Project tempo to allow the Event to stretch.

Reproduction sequence :

  • Open the Lower Zone Editor,
  • Select an Audio Event,
  • In the Editor, place the Snap Point anywhere but at the Event Start,
  • Open either the Definition, AudioWarp, VariAudio or Hitpoints tab,
  • Toggle Musical Mode from the Editor Toolbar.
  • Result : The opened tabs get immediately closed.

Additional information :

  • The issue occurs each time the Musical Mode button is pressed, it does not matter if it is already enabled or not.
  • The issue only occurs when the Event is selected in the project window. In other words, if the Event is opened in the Editor but not selected in the project window, the issue won’t occur.

  • The issue does not occur with the Range and Process tabs,
  • The issue does not occur when the tempos are already matching and no stretching is occurring.
  • The issue does not occur when the Snap Point is placed at the Event Start.
  • The issue does not occur at all in the External Editor, it is exclusive to the Lower Zone Editor.

Added to the issue list, number 31.

Which exact version of cubase? Cause it seems similar to issue i get Sample Editor keeps forgetting layout settings

Does it manifests in v12.0.0?

This is on 12.0.30, I don’t remember if that bug was also present in previous revisions. In any case this has to be fixed.

Somehow I cannot reproduce it on my setup. Could you take Cockos Incorporated | LICEcap and try quick record gif and post it here?

Can you please do that for me and show the issue isn’t happening on your side ?
If you cannot reproduce it then it is either because you are not doing it right, or because you are on Mac and there is simply no issue on this OS. Please confirm.

editor tabs musical mode bug

Sure, I recorded with safe-mode disabled preferences (CTRL+SHIFT+ALT during startup)
So here how it behaves here (my preferences and factory preferences as well)

Did you tried with disabled preferences as well? Also I see that your cubase is set on french language, did you tried to change it to English also to disable windows scaling?

Here is:
Cubase 12.0.30
Windows 10 1909
No Scaling

None of this worked, the bug is still present.
Anyways, I don’t know how changing the language would fix an issue like this, and also launching Cubase with default preferences doesn’t change anything either, my preferences were still the same, it did not seem to disable anything.
In any case, this is a bug in the code and it has to be fixed.

There are situations in Cubase history that language messing some stuff (if i recall correctly there is problem with Japanese language in some areas back in 2007-8 :thinking:)

Anyway I hope I did it right on the gif and somehow it doesn’t represent like you described. So I would try to start from the ground and pin point what is difference between my enviroment/workflow vs yours (again if i followed your guides correctly)

In my career I see all kind of things with Cubase some of them are scary odd, and some are from stupid settings in bios for ex… The point is that some aspects of Cubase are very sensitive so it is worth dig deeper.

1 Like

Cant repro here in C12.0.30

Here’s the exact repro sequence I did:

  1. New Project
  2. Insert audio by any means (I imported)
  3. observe file’s tempo in Pool, and set project tempo to a different value
  4. Select audio and open sample editor in lower zone
  5. Open Inspector Tab “Definition”
  6. Click on Musical Mode button in editor toolbar

Result here, nothing happens except for toggling Musical Mode.

I tried with rulers set to Seconds and Bars, and with Tempo Track activated or not.

Hey you know what, when the Event isn’t selected in the project window, there is no issue…
But again that does not fit your videos where the Event is selected.
For information I have completely removed Cubase, wiped every single file, and reinstalled it again. That simply did not fix any of the issues I’ve found in this software so far.
Here’s my preferences in case you want to test it, and I’d like to try it with yours too, we just have to find what setting is causing the issue to occur.
UserPreferences.xml (210.2 KB)

editor tabs musical mode bug 2

Oh, well, forget my last post, I have found what causes the issue, and you won’t believe what it is.
It is caused by the Snap Point (again)… I am just speechless with that one.
If you put the Snap Point at the start of the Event, then there is absolutely no issue, whether the Event is selected or not.
But, when the Snap Point is anywhere on the Event but not at the very start, then the issue occurs, but only when the event is selected.
This is the weirdest shit I’ve seen in a while. For real.

Yes indeed snap point is the trigger, so you have to correct repro sequence.

OP was corrected.

Also I’ve discovered three new issues while experimenting with this one.
Yes, three.

  1. When the Definition tab is opened, the waveform size and other zoom and display settings get reset every time another Audio Event is selected in the Project Window. (Also happens when triggering the bug explained in this current Topic). As you might know, each Event in the project can have their own waveform size and zoom level independently, but when this issue gets triggered, it resets it for every single Event in the project. We even have a yellow pop-up “Zoom mode has been changed” or something like that… Completely counter-productive.
    (BUG : Sample Editor Definition tab resets the waveform Vertical Zoom level when selecting Events)

  2. When Auto-Scroll is enabled in the Editor, and the Cursor is placed outside of the Event (before or after, and eventual stretches caused by musical mode must be taken into consideration too), and when the Snap Point is NOT placed at the Event Start, toggling Musical Mode causes the Editor to perform a zoom out.
    (BUG : Toggling Musical Mode can make the Sample Editor perform a zoom out)

  3. Dragging and releasing the Snap Point on negative grid values then enabling Musical Mode can cause the Snap Point to jump to a random place on the Event, and eventually trigger the issue 2 from the issues wiki if it lands beyond the Event End.

I’ll post all of those three issues separately.

Additional findings :

When the Definition tab is closed and the other tabs are open, only the AudioWarp, VariAudio and Hitpoints tabs get closed, and the Range and Process tabs remain open.
If the Definition tab is open, then all the six tabs get closed.

definition tab musical mode bug

I have found other ways to trigger the issue, please refer the the following topic :

Lower Zone Editor Tabs get closed when doing specific actions