Bug? Tracks in closed folders don't move after CTRL-A, drag

Hi - I wanted to drag my entire project left, so I selected all with CTRL-A, and clicked-held-dragged one of the tracks.

It worked fine for all of the visible tracks, but tracks in closed folders were not dragged - their position remained unchanged.

Anyone else?

Thanks -

Hi,

I will try.

To make sure even tempo changes, signature, etc., select the area you want to delete by Lisa & R Markets, and select Delete Time from Edit > Range menu.

Thank you for the favor of your reply, Martin!

Sorry, what does that mean?



Sorry, I may not have explained my issue properly.

I have a project that begins on bar #50. I want to CTRL-A select the whole project and drag it left so that it starts at Bar 1.1.0.0.

Nothing to delete, etc!


Thank you!

Hi,

I just tried it here on my system, and I was able to move it (via drag and drop). Even the data hidden in the collapsed folder moved.

Btw, I know, you want to “move the whole project to the left”, but actually this is the same as “delete bars 1-49”. The Tempo and Signature tracks have always an event at 1.1.1. So when you select all (with Tempo or Signature event at 1.1.1), you cannot drag it to the left then. Because there are already events at 1.1.1 (the Tempo and Signature). Because of this, you have to use the Delete Time, or you have to deselect these Tempo/Signature events at 1.1.1. Is it clear?

Hi, thank you, Martin!

Yes, I figured out I had to delete that one tempo point at time zero. It’s possible that fixed the issue of the data in the closed folders not getting dragged left with the rest of the project - I can’t remember if I tried to do that after I realized I had to delete that initial tempo point!

I will see how that works next time.

I assume that the CTRL-A and drag technique is functionally equivalent to the Delete Time one, once the tempo and sig data at 1.1.1 are erased?

Thank you!

Hi,

You cannot erase/delete these events. These events are always present. You have to de-select them.

At the end, the result of Delete Time function, and the drag-and-drop way is the same.

Thank you for your response, Martin!

I could have sworn I was able to lasso-select the tempo point at 1.1.1.0 and delete it!

I’ll check again, just to make sure I’m not remembering incorrectly.

Thanks!