Bug? Unable to deactivate mouse for note entry

Under General–>Preferences–>Note Input, I unchecked the box labeled “Enable note input using the mouse.” However, it doesn’t seem to work as intended. I’ve tried restarting the program, but that doesn’t fix it.

I was able to turn off the option of double clicking making it jump from Engrave to Write mode.


Never mind, I see I also need to turn on the “Select” mouse pointer icon.

It’s a small thing, but I find that confusing. If I disable mouse note input in Preferences, I don’t want it popping back up.

All that Preferences option does is determine the default state of the “Select” button in the toolbox when you start a new project or open an existing one. It doesn’t forever forbid mouse input, though provided you don’t then change the state of the “Select” button it is effectively forbidden.

Dear Daniel,

I have a similar question or request.

Dorico is more agile than Finale.
However, sometimes I see some changed items in scores. It occurred by unconscious mouse click or drag.

I experienced already while using Dorico 2, but it was still OK.

As some users already mentioned, The GUI of Dorico 3.x behaves somewhat stranger.
The position of tempo markings, dynamic marking, playing techniques are moved more frequently.

Therefore, it would be probably good to provide “lock mode” (disable any item input including notes and dragging items) and “edit mode”.

What do you think about it?

I think if you’re encountering issues like this it will be something performance-related: Dorico is busy doing something else when you click, and the result is that you end up with a “hidden” edit that gets processed once Dorico has finished doing the previous operation. The whole design of the application is to prevent unintentional edits by only moving things if you’re in Engrave mode, but when you’re in Engrave mode, of course, the score is much more “live” to mouse-editing than it is in Write mode.