Bug: VST2 plug-in path list keeps being reset in Preferences in Pro 4

I use the OT Tallin library, which I understand is VST2. This all worked in 3.5, but not in 4. Although the Sine player is VST2 whitelisted, the path list above on the Preferences page was not properly copied across from 3.5. I use a separate D drive for my libraries. However, when I tried to manually add the D: drive paths to the path list, they were initially accepted when I hit Apply. However, Sine still didn’t appear in the VST instrument list, and when I restarted D4 the VST2 pathlist was back to only listing C: drive paths, and the D: drive paths were gone. Re-tried this several times, tried resetting the audio engine cache and data. Nothing worked. Help please.

Hi @TBB , I wonder because I tried myself and it works for me.
The VST2 paths get written to the file C:/Users/your-name/AppData/Roaming/Steinberg/Dorico 4 AudioEngine_64/Vst2xPlugin SearchPaths Dorico 4 AudioEngine.xml
After you press the Apply button, can you please check that file and see if it contains the the new path? You can open the file in a text editor or even better Internet Explorer because that one can interpret XML and shows it nicely formatted.

I’m a little confused here. I use the F: and G: drives for my actual libraries but the paths to the plug-ins are in fairly standard locations on the C: drive. You’re saying that both the actual sample files and the plug-in paths are on D:? And that Dorico 4 does not seem to be able to store D: paths whereas 3.5 can?

On my system, the SINE plugin is installed to C:\program files\Vstplugins which is the default path. SINE libraries are on F: Still, if it was working with 3.5, I see no reason why there should be an issue with 4 and there isn’t with me. I think Ulf is right is suggesting you first check to make quite sure that the SearchPaths xml file does correctly match what you see in VST Plug in Preferences. If it really can’t write to D: then perhaps there really is a bug or your D: drive permissions have somehow changed.

I’ve noticed that the SINE player itself can have issues with paths and it’s not inconceivable that the issue might be there. Especially if all your other vst2 libraries have migrated successfully. Your description of the problem does though suggest an issue with Dorico itself.

Hi @Ulf. Thanks for getting back to me so quickly. Well, golly gosh, it’s working this morning - in that while D4 didn’t carry over the VST2 path list completely from 3.5, when I added the missing paths manually, this time they “stuck” and Sine is now discoverable. I’m really not sure what I did differently, but I’m now a happy camper. (By the by, I noticed that D4 also didn’t carry over the ASIO driver settings from 3.5 - I had to do that manually too.) Anyway, thanks (and thanks to @dko22 too).


1 Like