Bug when working with "Bars and Beats" time format

Wavelab Pro 11.1.20, Windows 10 Pro 21H2.

I sometimes work with the “Bars and Beats” time format to arrange several clips according to their tempo in a montage. Most of these times I can work without “Show Ticks” enabled (thanks Wavelab 11!), but on some occasions I have to use it and it would be easier/more precise to enter a value for the Bar : Beat : Tick manually in the Clips tab (by keyboard input or by changing the number with the up/down arrows on the right side).

I usually work with a setting of 100 Ticks per Quarter Note, and I noticed that whatever value I enter is not applied, instead it seems to be divided by 10 (rounded down, or just cut off the last digit). For example, when I enter 75 as Tick value for the starting position of a clip, to position it three-quarters between two beats, the resulting time is changed to x : y : 007 instead of x : y : 075). Furthermore, when I use the arrows next to the time in the Clips tab (or the up/down arrow keys on my keyboard), the value goes upwards just from 1 to 9 (and loops back again from 1 to 9) and does not increase the Beat and Bar value, downwards it goes from 9 to 0 (and loops back again from 9 to 0) and does decrease the other values accordingly.

I did some testing and found, that the same issue happens with a setting of 1000 and 10000 Ticks per Quarter Note. Also, this problem doesn’t only apply to the positioning of a clip in a montage, but to the positioning of nodes of an automation/envelope curve and markers too (even in the audio editor for markers). When I changed the Tick setting just by 1 (to 99/101 - 999/1001 - 9999/10001), everything worked as expected and entered values were applied correctly. I did try some other random settings for the Ticks and all of them worked, so there seems to be specifically a problem with the setting of 100/1000/10000.
I also can reproduce this problem in Wavelab Pro 10.0.70.

Thanks for the report, I can reproduce too.