Bug with Adding Playing Technique

Hi All:

Just a quick bug report.

Dorico 2 Pro on a Mac with High Sierra 10.13.4

I added a new playing technique under “Strings” (to say “slap”). It looks OK attached to the note, and showed up correctly in the side panel until I closed and reopened the file.

See the attached graphic.
Screen Shot 2018-06-22 at 8.38.07 AM.png

Addendum. May be part of a larger bug rather than relating only to the item I added. This is 30 minutes later.

Tried rebooting program, then rebooting system, then closing and opening the panel modules and resizing the screen.

Here’s a link to the actual file in case you want to look at it.

Have you tried to close an reopen Dorcio?

Yes. See above.

Further addendum: Still uncertain of the cause of the bug, but I found an interesting symptom workaround. When I select “new window” I get a screen with all the expressions laid out properly. Then when I closed the original window, it remained OK. See screen shot of the original window and new window side-by-side.


When I close the file and reopen, the problem returns. It seems to affect most of the categories in the right panel… including clefs, key sigs, time sigs, tempos, dynamics, ornaments, and playing techniques.

Hope this helps.

Do you find that this goes wrong if you open this project by double-clicking it in the Finder, but looks OK if you open it via File > Open from within Dorico?

Trying that…

Yup. That is exactly what it does. Wouldn’t have occurred to me, but now I see that this is precisely what the “new window” approach suggested.

I’ll open it from inside Dorico for now. Thanks for the fast response, Daniel! Wish I could have been in NYC for your talk last week. I missed you by just a couple days.