Bug with MIDI OUT

Hi guys,

I have a weird behavior with the MIDI outputs… It is not related to the last version 1.4.7 because the issue occured on 1.4.4.

As you know, I use VST Live since a long time and my project works fine and have the same MIDI parameters since the beginning.

I’m using a ESI M4U device, so with 8 In/Out midi ports.
I use ports 1 to 4 as Midi inputs and the ports 5 to 8 as Midi outputs.
I have connected a M13 pedal to port 5, a M9 pedal to port 6 and Lehle pedals to port 7.

I don’t know why and how, but during our rehearsal, everything worked fine until one moment (I cannot explain what’s happened). Impossible to control Midi outputs…

After investigation, I figured out that now, MME Midi:MIDIOUT5 (ESI M4U eX) became port 4, MME Midi:MIDIOUT6 (ESI M4U eX) became port 5 and MME Midi:MIDIOUT7 (ESI M4U eX) became port 6…
It means that if I want to control Lehle pedals, it will work with name Second Ampli Gtr.

I tried to reinstall VST Live with last version V1.4.7 but same problem. I tried to create a new project, same problem.
I tried on cubase, port 5 is port 5 and so one… So the issue only occurs in VST Live…
image

There is no problem with Midi inputs, I tested all the 8 ports and they work correctly.
Only Midi ouputs are shifted.

Is there a way to reset the midi as we can do with audio ?

Hi @magicguigui,

and it worked in previous versions? Like 1.4.0? We’ll check anyway. Thank you for the report.

/Michael.

Hi @Spork,

It appeared on previous version first. Then I tried to reinstall the previous but still the issue.
And then I tried with the new version, but still the same issue.
I mean, it is not an issue related to a specific version.
I use the same project since some months, I use the V1.4.4 since the release without problem.
Yesterday, everything worked fine and suddently, the issue occured.

We use a lot of Windows MIDI devices, but this never happened.
However it could be imagined that you added or removed devices, and Windows shifted the MME ports internally. It is not likely, because the name is also taken into account, but you never know.

I don’t think so, because as I explained before, if I run Cubase and send message to my MIDI card, the ports are correct. But then If I send message with VST Live, ports are shifted.

Hi @magicguigui,

could it be that you are running Cubase or another host in the background which is using your ESI M4U device? It could be that this host is already using a MIDI Port. And in that case the Port is blocked. And that could confuse VST Live.

And if that’s true, you need to close both applications and start only one to get the full access to the MIDI Ports.

/Michael.

Next version will attempt to avoid that, you may want to check again then, thanks Micha. But we need to repeat that using VST Live along with other audio software is not supported.

Hi @Spork, @musicullum,

If I start VST Live while Cubase is running, VST Live show pop up saying that midi port are already used, so VST Live cannot open the midi ports.

So this is not the problem.

I have restart the PC to only run VST Live without any soft and the issue is still present.
Also, there is no problem with Cubase, it means that there is no relation with Windows.

thank you, @magicguigui. We have fixed a bug which should probably solve your problem. Please try again with the next Pre-Release and let us know if it works for you.

Thank you,
Michael.

1 Like