Bug with RME ASIO?

Hi

I’ve been having a problem since upgrading to Cubase 6 from Cubase 5 (I never got this problem in Cubase 5), details as follows:

My system:

Windows 7 x64, Asus P67 Pro, Intel i7 2600K, 8GB DDR3, RME HDSPe PCIe (most recent driver), Cubase 6.0.1 (running 32bit as I use many VST instruments that are not 64bit compatible yet).

Problem:

Whenever I launch Cubase 6.x, regardless of whether it’s with a new or existing project, if I play anything out (audio or VST) the sound is ‘crackly’. So, every time I launch Cubase I have to go to Device Setup and switch the ASIO driver to something other than my default RME hammerfall ASIO, then back to the RME ASIO device again to get rid of the ‘crackly’ sound.

Is this a known issue?

Cheers

swerver

NB: I notice in the FKBL that there is a defect listed (ID 27682) which relates to RME ASIO devices crashing Cubase, but this isn’t happening so probably doesn’t relate to my problem.

Have you checked your IRQ’s? I use a HDSP 9652 with zero problems

IRQs? There’s a blast from the past :smiley: …I’ve not done anything IRQ-y for at least 10 years. I thought with a modern OS (W7 x64) and modern hardware this sort of thing wasn’t necessary any more? In any case - this all worked fine on the same hardware/OS with Cubase 5.x, so it is not an IRQ issue.

Cheers

swerver

No, IRQ should not be a problem with the Intel APIC used on most (all?) modern motherboards.
Can’t think of anything specific regarding your issue though, gone through all the usual troubleshooting steps?
Stripped computer with only your HDSPe?
Tried different PCIe slots?
Same card, OS and Cubase on another machine?

/A

I haven’t done much troubleshooting yet tbh, I have a reliable workaround which is simply to switch ASIO devices and then switch back again, then the problem is fixed - it’s just a bit of a pain to have to do this every time. As far as the hardware/PCI slot goes, as I mentioned before this only happens in Cubase 6 - if I run Cubase 5.5.x on the same system I don’t get the problem. So, it seems it’s some kind of bug either with Cubase 6, or a combination of Cubase 6 with the RME driver.

IIRC, there may a preference that tells C6 what sound card to use …? Maybe under “Audio” … sorry, not in front of music computer currently -

I sometimes fix odd soundcard problems by changing the Windows (7) sample rate and then back again. If the sample rate shown is not what you use then change it to that one.

Ctrl Panel /Sounds / Properties (Playback & Record prop’s) / Advanced tab.

Thanks for the further replies. I have a reliably reproducible problem and a reliable workaround - this suggests the problem is a bug. How do I get it added as a bug?

BUMP

Hello,

How do I get it added as a bug?

When the issue is reproduced by other people and us. Till now there are no other reports world wide. So it is a “local” problem on your machine at this point.

Cheers,

Chris

Hi Chris

Thanks for your reply, I understand that this is currently only an issue on my system until someone can reproduce it, but is this something Steinberg do? Do Steinberg have the same audio hardware they can test this with, or do you simply just wait until another customer reports it? At what point do you actually ‘create’ the bug and start investigating? How many people need to report it before Steinberg investigate?

Many thanks

swerver

I’m thinking this is either an ASUS or Win7 issue as this happens to me occasionally with my Multiface II PCIe interface and also used to happen occasionally with my previous Delta 1010 … i just do a restart then all is absolutely fine again!
I would guess it’s more likely to be an ASUS issue seeing as i have an ASUS P6TSE :wink:

Hi Matt

It doesn’t happen in Cubase 5.5.x on the same system, so logic suggests the bug is with Cubase 6.

Cheers

swerver

Ok mate… but for reference it happens to me on both versions of cubase… not a major hassle really as it always settles down perfectly after a restart.

Hi swerver,

I am also using rme HDSPe’s with Cubase 6. Aparrently the rme driver exposes some problems with Cubase 6 which did not show up in Cubase 5.x.x. There is a new public beta for a new rme driver version available on the rme website, see http://www.rme-audio.de/forum/viewtopic.php?id=10466.

The new driver beta works very well for me, fixed the problems I had with Cubase 6, and has some important performance improvements when you are using multiple HDSPe cards (I am using 3) in a multi cpu / multi core system.

Btw, for other rme product lines, similar beta drivers are available.

Regards, Mikael

Hi Mikael

Many thanks for this :smiley: , I figured it might be an RME issue. I had visited the RME website but only found the release version of the driver which I’m already running. I’ll give this version a try when I’m next in the studio and I’ll update this thread with the results of my tests.

Many thanks again! :smiley:

Cheers

swerver