Bug with Split Tool Key Modifier when Using Combined Selection Tools

I’m just wondering if someone can confirm a bug I’m having in Cubase 10.5 on macOS High Sierra that affects the Combined Selection Tools. This has been happening for me since the initial release of 10.5, and persists with this new update.

When Combined Selection Tools is activated, using the Option key modifier, set at its default to split, is unreliable. Sometimes it ‘sticks’ and stays on screen even after releasing the Option key, but more often it just won’t appear at all. I’ve noticed this is usually after having selected/copied/pasted etc. using the Range tool - even if I hover around the lower part of an event and see the Object selection tool, the Option key won’t bring up the Split Tool. The only way I can get it to reappear again is to actually select an event - the Split Tool can then be accessed by the Option key modifier.

I use this key modifier all the time, so it’s making the Combined Selection Tools not really usable for me at this point.

Mark.

Hi Mark,

I have tried to reproduce it. I can reproduce it only, when any Range is selected by the Range tool. Ot doesn’t matter, if the Range is made by the dedicated Range tool, or by this Combined Tool.

The reason is, this Split modifier simply doesn’t work, when Range Tool is selected. So if you make a Range selection, the Alt modifier for the Split doesn’t work (even in case when Combined Tool is selected) at this moment.

Can you confirm this behaviour, please?

Hi Martin.

I’m seeing the behaviour you mentioned, but it goes further than that for me.

Even when I hover with the mouse over the lower part of an event with no range selected so the Object selection tool becomes visible, often the Alt modifier for the split tool will not work at all no matter how many times I click it. The only way I can get it working again is by selecting an event with the Object selection tool - this seems to ‘wake it up’ so it realises it’s no longer in Range mode and the key modifier is again available.

Hi,

For me this is reproducible only if a range is selected.

Could you please make a vide screenshot? Maybe we will see something helpful, what you are overlooking…

Hi Martin.

Thanks for bearing with me. I’ve had some issues with my iMac so had to do a clean install of Mojave. I’ll need to spend a couple of days reinstalling all my music software, but I just wanted to reply and say I had installed the latest Cubase version as the first application on this fresh computer, opened it up, and the problem persists. It will be difficult to show this on a video capture because you won’t know when I’m hitting the Option modifier, but I really feel like I’m not missing anything here and it’s just not working correctly for me, especially considering the inconsistencies in behaviour. :slight_smile:

On a new session, I turned on the Combined tools then did these steps:

  1. Hover over the lower half of an Audio or MIDI event (showing the arrow). Hold Option. It shows the scissors. Now hover over the upper part of the event. It’s now showing the range tool. Hold Option. This also shows the scissors for me. Sometimes the modifier sticks and the scissors stay on screen even after releasing the Option key. I have to tap it again to make it disappear.
  2. Now hover over the upper part, select some ranges and move them around (you may need to do this a few times to get this issue to occur). Click out so no ranges are selected. Now, hover over the lower part of the event so it shows the arrow again. Hold the Option key. The scissors will not appear.
  3. The only way to get the modifier to work again is to select a region with the arrow tool. It’s like Cubase is stuck in range mode and needs this step to snap out of it. Now, every time I hover on the lower part of an event to show the arrow tool, I’m able to use the modifier. I can ‘break’ it again by repeating step 2.

If you’re still unable to recreate this let me know and once I get my machine back up and running I’ll see if I can find some video capture software that will show you the keys I’m hitting while displaying what’s on-screen.

On Mac you can Show Keyboard Viewer, then we would see the Option/Alt holding on the screen.

This is the scenario I described. You said

This is actually impossible with the Range tool selected. If you click out with the Range tool (so to the upper part of the track in case of Combined Selection Tool), the Range of length 0.0.0.0 has been created. So again, you have a range created (the Range is almost invisible, but you can see the blue line, if you know, where to search for it; and you can see it in the Info Line in any case), therefore the Split tool doesn’t appear.

Sorry, I’m a little confused by the implementation. Again, thanks for bearing with me. I’m used to using the Combined tools in Pro Tools and Studio One and finding the implementation here, if you’re saying this is how it’s meant to behave, really strange.

Are you saying that if I hover on the lower part of an event after using the range tool and it shows the arrow icon it is NOT switching back to being the Object tool (is still the Range tool)? That I have to specifically use the Object tool first (by clicking on an object, for example) for it to switch back before having access to the Object tool’s full functionality (its modifiers)? This seems like an unnecessary step. I would think it would just switch between these tools depending on where the mouse is hovering on the event.

How then do I revert to the state I’m describing in step 1, where the split tool appears when holding the modifier on both the range tool (when hovering over the upper part of the event) and the object tool (when hovering over the lower part)?

It also still doesn’t explain why the modifier sometimes locks on the split tool after releasing the modifier, with me having to hit the modifier again for it to disappear, but perhaps this a separate bug that has made the expected behaviour seem stranger to me.

Hi,

I made a Feature Request out of it and sent it to Steinberg.

Thanks Martin, I really appreciate it.