bug - wrong bar rests

Occasionally, when working in a score with a time signature of 4/2 or above, in which Dorico draws the bar rests as breves instead of semi-breves, Dorico will fill 4/2 (and above) measures with semi-breve rests instead of breves. Fiddling with it to try to make it display the right thing just seems to anger Dorico.

Here are some pics.

  1. I want to add 20 measures or so to this.
  2. I add 20 measures. This is what I get.
  3. I try adding some notes and erasing them to try to kickstart Dorico’s proper rest filling. Some lines are responsive; some are not. Some are only responsive up until a note has been added. Some will remain responsive up to that point if the note is deleted; some will revert to semi-breves.
    (not pictured, though I can upload these if you’re really interested)
  4. I try changing the time signature. Makes it worse (everything after the time signature is now a semi-breve).
  5. Trim the flow, delete the time signature, and this is the result (same as pic 1, but final measure has semi-breves; one part has a semi-breve in the second to last measure).

Oh yeah, and restarting Dorico fixes it temporarily, but the minute you try editing the music, the wrong rests appear again.

I’ve not seen this problem. If you can provide me with a project that reproduces it reliably, then we will be glad to take a look and try to figure out what’s going wrong. Thanks! (You can email it to me at d dot spreadbury at steinberg dot de if you don’t want to attach it here.)

Daniel, it’s fairly easy to replicate this.

  1. Start a new project.
  2. Set meter to 4/2
  3. Go to Notation Options > Rests > Bar rests > Bar rest design in long time signatures and set to “Double whole (breve) rest”
  4. Then start typing notes into your bar.

You’ll see that any new bars that appear will have regular semibreve rests, whether these bars have appeared via the popover or have been automatically when you’ve typed notes in.

A cursory play would indicate that simple fix is getting all the notes input, and then toggling the aforementioned setting in Notation Options. There may be other undesirable consequences that I’ve not witnessed in a short (2 minute) experiment.

pianoleo’s instructions do indeed reproduce the problem for me, though I’m nonetheless happy to attach the score in which I first noticed it. The pictures that I attached in my previous post came from the end of Flow 1, so if you add a handful of measures there, it should produce the issue.

Knowing that simply toggling the option seems to clear it up makes it feel much less dire. When I first ran into it, I had nightmares of a corrupted file and worried about saving it (which happened in Finale from time to time on large enough scores…).

While we’re on the subject, I wonder if I might propose a small expansion of the feature. I’d love for meterless measures that contain at least eight crotchets’ worth of music to also have the option to show breve rests. If you glance at Flow 2 in my project, you’ll see why this would be relevant :slight_smile:
Atlantis Short Score 2.8.zip (1.52 MB)

Thanks for reporting this – I can indeed reproduce it and we will fix it in due course.