(BUGBASE) Midi Issue between Cubase 5.5.2 and Reason 5.0.1

So here is my issue.

I open cubase…
I open Reason…
I create a new project in cubase…
I enable mix L&R reason rewire…
I create a midi track in cubase…
I go to Reason and create a piano instrument…
I assign the midi track in cubase to the Piano Combinator in Reason…
I arm the midi track in cubase to record…
I record a basic piano part… (I am not much of a piano player)
I quantize the piano part in cubase to 8th notes…
I press play to listen back to piano part and here is the problem…

The piano part occasionally plays notes late ie it sounds like it is hiccuping or missing time…

for example imagine having a snare drum playing 1/4 beats ie a straight 1, 2, 3, 4 over and over and over… It is quantized so every beat is meant to land perfectly yet every now and then it decides to go… 1, 2, 3 and a half 4…
ie the 3 beat plays back half a beat late but on the score or on the grid it is showing as being perfectly placed on the 3.

If i then go back and play that bar by itself it plays perfect…

It is really giving me the you know whats…

If I assign the midi track to HalionOne and play a piano in it it plonks along fine and dandy in time…
If I export the midi track and import it into the Reason Sequencer and assign it to the Piano and play it back it is perfect.

The issue is through cubase to reason via midi…

Some one give me a solution to this problem please.!

I even went to the trouble of fully rebuilding my system today and starting fresh to see if it made any difference which it did not!

My System is as follows:
Cubase 5.5.2 32bit
Reason 5.0.1
2 x Steinberg MR 816x
1 x Faderport
OS : Windows 7 64bit
CPU : intel i5 760
MB : Intel dp55wb
Ram : 4gig Kingston ddr3
Waves Platinum V7
Waves JJP Collection


I had the exact same problem with the following :
Cubase 5.5.1
Reason 4.0.1
1 x Yamaha O1X
2 x Yamaha i88x
OS : Windows XP Pro 32bit
CPU : intel i5 760
MB : Intel dp55wb
Ram : 4gig Kingston ddr3
Waves Platinum V5.9.7

Oh I had no problem like this with my previous computer :

Dualcore
2 gig ram
O1x
2 i88x
windows xp pro
cubase 5.5.1
reason 4.0.1

Someone must know what it is

Greg

someone suggested trying reaper and rewireing to determine if the problem was rewire or cubase

Tried Reaper (Found it via google search)

Midi rewired stable in reaper to reason with the same midi piano part playing (ie i exported the midi info out of cubase and imported it into reaper.)

So the problem lies in cubase!!!

I am really quite you know what about the situation.

HELP PLEASE!!!

Greg

Update…

Installed everything onto my 4 year old laptop running win xp pro on 2 gig ram with an intel pentium dual cpu 1.73ghz.

SAME DAMN ISSUE!!!

So I am now at a point where I really feel its a CUBASE fault and I am really losing my mind on it!

Someone must have an answer to this problem…

Greg

I am on C5 5.5.2 and use Reason 4.0.1. I have never had the problem you have described.
So it seems that Reason 5 may have introduced a problem. Have you checked out the Propheads forums to see if anyone else is having issues?
Also, I don’t know if this matters in relation to Rewire, but check your project synchronization setup page, and make sure in the MIDI Clock Destinations section, that you have a check mark next to " MIDI Clock follows project position"
I am sorry I don’t know what else to suggest.
good luck

Tried the midi clock follows cursor thing didnt help… Will try uninstalling reason 5 and installing reason 4.0.1 and seeing if that is stable… I dont think it will be as I was having this issue before I upgraded reason to try and solve this issue lol money out no fix yet its killing me!

Greg

Same issue with reason 4.0.1 still slipping!

Im really annoyed :frowning:

GReg

Found this today!

http://www.cubase.net/phpbb2/viewtopic.php?p=972879&sid=e89fcc6f67ec6fa712efabaca2094bc8

This topic shows I am not alone!

I need a solution :frowning:

GReg

UPDATE!!!

Installed Cubase 4.5.2 and tested midi rewire stability… SUCCESS!!! Running at 48khz 96 sample buffers latency 3ms ROCK SOLID…

Therefore this IMHO Proves that the issue lies within CUBASE 5! I tried 5.0.1 and it was still CRAP… Tried EVERY update up to 5.5.2 and they were all CRAP!!!

STEINBERG SORT THIS CRAP!!! OUT!

GReg

Hi GReg,

as I see you have found my post on the old forum describing exactly the same Cubase/Reason MIDI problems. I was already in contact with the Steinberg support but unfortunately they were not able to reproduce the problem on one of there test systems (at least they told me so). I also tried a different sound card but that did not sort the issue out.

There is only one thing that I have found as a kind of workaround: On my system the problem correlates to the sampling rate. If I use 48 KHz the timing is really bad. But when I switch to 44.1 KHz the timing is a lot better. Have you tried changing your sampling rate? Would be interesting to know if this will change the behavior, too.

Regards,
Stephan

I have steinberg support here in Australia getting onto Germany with an urgent request to find and fix this issue!

I am losing thousands of dollars each week due to this and I am Pi$$ed off!

I am now in the process of trying to go back to Cubase 4.5 temporarily till it is fuxed but this is an UNACCEPTABLE work around as I have paid hard earned money to upgrade my software to only end up in the position I am in now!

NOT HAPPY!

OMFG

This is amazing!!! I Think I have solved the issue!!! I am not holding my breath but this may just have fixed it!

So as I said I installed Cubase 4.5.2 and it was rock solid… Unfortunately I cant Just open my 5.5.2 projects in 4.5.2 obviously…

SOOOOOO I opened 5.5.2 to start the long and painful task of exporting the projects in some manor to get them into the old 4.5.2 when I decided for shits and giggles to press play… What happened next made my heart stop!

It played the track the whole way through without a hiccup!!!

It seems that by installing 4.5.2 it has changed some system files in windows I assume which have stabalized 5.5.2!!!

This would explain why my old box worked flawlessly as It has been my main studio box since 2005 and has seen SX3 transition into 4.5.2 and then 5.5.1 as time went on by!

I am hoping this has seriously solved my issue and will report back if the problem is not infact solved!

Lets pray it is…

Thankyou everyone who viewed this and has been trying to solve my issue I appreciate you all very much!

Hopefully this will also lead steinberg to find the cause of the issue!

Greg

Hi Greg,

this is definitely worth a try. I will check and report if installing 4.5.x also resolves the issue on my system.

Regards,
Stephan

Seems Like I may have been wrong…

Problem still seems to be there…

I am so depressed because of this!

Im seriously losing my mind!

Greg

Seems i was mistaken with 4.5.2 as well for it is glitching too!

Just not as bad but still doing it.

This is seriously sending me insane!

Ok so I tested at 44.1 khz and as per your results I was stable…

SOOOOO… Problem at the moment still exists at 48khz…

All my projects for the past 10 years have been tracked at 48khz

How the heck am i meant to resample my projects from 48kz to 44.1khz EASILY!

Greg

Hi Greg,

44.1 KHz isn’t the only sampling rate that works. On my machine, it is the following pattern:

  • 44.1 KHz: good
  • 48 KHz: bad
  • 88.2 KHz: good
  • 96 KHz: bad

Very strange, but at least there is a pattern. Hopefully, someday somebody at Steinberg will be able to reproduce the problem and provide a fix. Maybe, the problem is in the Rewire protocol but on the other hand: I have tried the same thing using Reaper, and there was no problem at all.

Regards,
Stephan

I agree with stanft. Are you working at 48 for games or movies? If not I wouldn’t bother. With any DAW it’s best to work at the standard settings and really test any non-standard settings for reliability at every version change just to make sure of system stability.
Also could it be just the case that you have Reason running at 44.1 & Cubase at 48 and hitting the buffers?

As to changing the sample rate it can be done in the Project Setup (shift+s)

Conman, When you increase the sample rate you also increase the quality of the converters and also you lower the latency of the system… Your plugins also increase in quality as well…

Define standard… standard for what… a cd is 44.1khz and 16 bit… are you suggesting to lower the bit rate too or should i take advantage of the increased headroom by running at 24bit… I have been a producer and engineer for a very long time and have studied alot about bit rates and sample rates… Do some reasearch into the advantage of higher sample rates and bit rates…

Reason is not running at a diff sample rate it is running via rewire… The two softwares sync together fine… If I sequence in reason there is no timing issue it is only if the midi sequencing is done within cubase and the sounds being generated in reason…

In regards to stantf he too wants to run at 48khz he is sacrificing his sample rate as a work around and is just as annoyed as I am about the fact that there is a major bug here…

I appreciate you taking the time to read the post and respond but please read it fully before telling me I am wasting my time by running at 48khz…

Once again I will put it out to STEINBERG to please test for this bug on your test systems… If in fact you cannot replicate it then please inform me of the hardware combination within the PC you test it on please and I will purchase that hardware… I am losing money here every week…

Greg

I would agree with conman completely. 48kHz offers you no advantage whatsoever UNLESS 48kHz is the sample rate of the tracks destination media. We work at 48k because we are working to film, not because of any perceived advantage. Otherwise I would still work at 44.1k, mainly because I use some samples which are 44.1 and upsampling to 48k is a messy process. Especially given that they are heavily limited. At those levels the doensampling/upsampling process can introduce ‘overs’ that werent there before. Working at even multiplications of your destination sample rate is a good idea to avoid these anomalies “chek out the ‘Gibbs phenomenon’” due to unresolvable mathematics. 88.2k to 48k works, 96k to 44.1k does not, nor does 48k to 44.1k. So unless you have a good reason to work at 48K (ie. you’re working to film or games), you shouldnt be losing thousands of dollars a week just to hold to working at 48k when there is no need. If you’re working on something thats going to CD, you’re doing your mixes more harm than good.

But I digress. In regards, to the MIDI bug you’re having, Ive not experienced that here with both C 5.5.2 and Reason 5.01, but then again I tend to keep the MIDI in Reason. Someone on the Props forum might be experiencing the same thing you are going thru. No doubt it is an issue from Cubase’s end - as you would know Reason is very solid when it comes to bugs.

Cheers,
Jim