Buggy behaviour with Plugins

Just upgraded to Cubase 11 today, and then spent the day installing and authorising plugins. It seems that Cubase gets more and more temperamental with each upgrade. I have all kinds of random issues.

  • Several plugins get blacklisted because Cubase claims they’re 32 bit, despite the fact that they are in fact 64 bit, and were running fine in Cubase 9 (also 64 bit only) yesterday. One of these is a GRMTools plugin, installed a part of a bundle of 12 plugins, 11 of which run fine, but this one got picked out randomly, and told it was 32 bit.

  • Several more get blacklisted with the simple message ‘Not a valid plugin’ - again despite running fine in Cubase 9

  • One (Image-Line’s Vocodex) gets blacklisted because Cubase says it can’t find a specific file in Image Line’s common files folder. So I checked, and the file was exactly where it was looking for it. More to the point, another Image-Line plugin, which needed the same file is running.

  • Several plugins actually made it through the scan, but then crashed Cubase when I tried to open them. And when I say crashed, Cubase simply vanishes, without any kind of error message. Again, nothing seems to link these plugins. For instance one is Soundtoy’s ‘Little Alter Boy,’ although a whole bunch of Soundtoys stuff is running fine.

Is there a list of known plugin issues anywhere? And are there any workarounds?

1 Like

Hi,

Are you sure, you have installed 64-bit versions of the plug.-ins only? Some plug-ins are installing both versions at once.

Cubase 9 supported VST2.x plug-ins. Cubase 11 supports VST2.4 and higher only.

I would guess, this is more on the plug-in side. Cubase doesn’t know about internal structure and architecture of the plug-in, where are some plug-in files stored. This message has to come from the plug-in.

Cubase doesn’t make complete test, of course. This is on the plug-in manufacturer side. Cubase runs just some basic tests.

Thanks for getting back Martin.

Yes, definitely sure I’ve only installed 64 bit versions - at least of the ones Cubase is complaining about. I do have a lot that insist on installing both (izotope, Vienna, etc), but obviously, when I see the warning that Cubase has blocklisted them, I go and check that the 64 bit version is still available. But in the case of the ones I’m talking about, they’re 64 bit only, yet Cubase is convinced they’re 32 bit.

In the case of those which Cubase calls invalid plugins, I didn’t think to check whether they were 2.4 or just 2. I’ll check that out.

I think you’re partly right about the Image Line one. Apparently they’ve changed things so that their plugins rely on a dll, but not rewritten the VSTs. Still strange, though, that it worked absolutely fine in Cubase 9.

Obviously I realise that Cubase can’t check everything about a plugin, but given that it’s crashing when trying to run plugins that were asbolutely fine in version 9, then I still stand by my complaint that it’s become less stable, rather than more. It’s a particularly nasty crash too - simply vanishes, without leaving a dmp file; task manager is convinced it’s no longer running, but it doesn’t let go of the audio driver, so I have to restart the machine in order to restart Cubase, or switch to ASIO4All.

Hi,

I have seen this here on the forum already few times. But I don’t remember the result. Could you please search for it? Are the plug-ins installed in the “64-bit folder”, please?

Probably Cubase 11 was running the “big test”, which runs when you start Cubase for the 1st time or if you install a new plug-in. Cubase 9 was running only the fast test, because the plug-in is not new anymore for Cubase 9. This might explain it. Also the tests have been extended from Cubase 9 to Cubase 11. There are more tests in Cubase 11 now.

Of course, Cubase is changing too. It might be, something what was wrong in the plug-in pass thru in Cubase 9 (by good luck) but it doesn’t pass thru in Cubase 11 anymore (no more good luck, because it has been fixed in Cubase 11 and the error in the plug-in is not accepted anymore).

Several plug-ins developers are using some workarounds to reach something. It can work in one version, but it might not work in other. Or there are bugs in the plug-ins, which again, might work in one version, but not in other. It’s the same as it is in every software. Something could work in Windows X and doesn’t work in Windows X+1.

Thanks again Martin.

I checked out the blocklisted plugs. The ones that it claimed were 32 bit, I simply uninstalled - most of them weren’t essential to my workflow anyway, and I guess I’ve been schlepping them around for a while now. Time to buy some new shiny ones.

The ones that were labelled as not valid plugins; you were right, they were almost all VST 2 rather than 2.4, so I’ve cut them out of my life too.

Still no idea about the ones that made Cubase crash, but it turned out that there was a slightly newer version of the only one I really care about, so that worked out ok.