Building Expression Maps

RUNNING Windows 7,i7,Cubase 6, 28 GB.


Is it possible to create our own Expression Maps in that we can use use Expression Map Key Switch assignments to call on Articulations that have been assigned to Bank slots using Kontakt Banks?
i.e:
Assign a Legato articulation loaded into K Bank slot 001.
Then in Cubase assign “c0” in a Expression Map to trigger the 001 Bank slot ,
and as follows:
K Bank 002 to Exp Map c#0
003 to d0
etc?


Are there any good tutorial resources for creating our own Expression Maps, preferably in Cub 6. I’m finding most of the older Cub 5 Forum referals on this subject (ie-“the-composers-approach.com”, etc) for Cub 5 are no longer up.
I’m also finding that the “Output Mapping” table in Cub 6 differs from 5.
G.C.

Yes, VST Expression can be set to transmit Program Change messages (which is how you select presets from within a Kontakt Bank).
The Cubase Operation Manual deals with it rather nicely, from page 420 onwards :wink:.

And, yes, VST Expression has indeed evolved somewhat since its introduction… it is much more flexible now :wink:.

RUNNING Windows 7,i7, Cubase 6, Kontakt 4, 28 GB


Hi again Vic, and to anyone willing. More about the Expression Maps—
I built about 30 of them last year in Cubase 5 through Kontakt 4, all routed to Key Switches. They played fine. I got sidetracked and have come back now in 6 to rebuild my templates, this time using Banks. However, none of the 30 odd Maps will play now, in 5 or 6. Obviously it’s me, I’ve forgotten something in this, but neither of the manuals is giving me an answer for it.
So with apologies for the length here—
Here’s a blow by blow as to how I’m attempting to do this that’s just not working for me.

1st, In Kontakt I load a New Bank assigned to midi channel 1 and drag articulatrions into slots 001, 002, 003 & 004.

Then, with the Expression Maps Remote Key Settings as follows:
Latch on
(In Mapping): “Start Key” = c0"
Key Mapping = “Chromatic”

I do as follows:

  1. Open Midi Ch Inspector > “Expression Map Setup”

2.Clk the “+” button.
3.Title new map
4.Click “REMOTE” (the default). Type in “C0” (etc).
5. Click “NAME” . Title = “LEG” etc.
6. In 1st “ARTIC” Column I select 'CUSTOM ARTICULATION"
7. In the Articulation box in the lower right I select “TEXT”,title this “LEG” and select
“DIRECTION”
8.In the " OUTPUT MAPPING" box (upper right hand corner) I click “+” above “STATUS”.
9.From this scroll down I select “PROGRAM” .
10. For 'DATA 1" I enter “001” (which defaults to “1”)
11. For “CHANNEL” I enter “1”.

I follow the same setup for the next Artic. excepting that the Key Switch, Artic etc assignments all move up one to c#, Stac, Data =" 2" etc.

I save this Map.
Then I open a new midi channel, assign this on the Cubase midi track to:
" ALL MIDI OUTPUTS" > KONTAKT 4 > Midi Channel #1 . In this tracks inspector I go to “Expression Map Setup” , Select “Load” and pick the just finished Map.

In the midi channel inspector the map and KS &Artic names are displayed. As I play through the Key Switches c0 to f0 the arrow scroll follows the key names but the articulations only play the 1st c0 Artic. On my 3rd attempt they moved from the 1st c0 Artic to the 2nd c#0 Artic and then froze on the c#0 Artic. All the while the arrow scrolls along with the keys on the midi controller as I play them. In the Kontakt Bank the Artic is unmoving also.

Again with my apologies for so much text, but I’m really getting stuck on stupid here now and there are no resources for the “HOW” that I’ve found beyond the manuals .
Can anyone tell see what I’m missing with this?
Thanks in advance—
G.C.

Well, I don’t see anything wrong there (I followed your recipe, and it works perfectly here :confused: Although, I’m on Mac OS X 10.6.8 here). I tested, using individual articulations from the Factory Library>Legacy VSL Library>01 Solo Violin>01 Standard Instruments.
Slight observation, though…
In that particular setup, you don’t need to set MIDI Channel to “1” in the VST Expression Map’s Output Mapping… you can just leave it blank for each of the articulations… unless you want to direct some of the articulations to a 2nd Kontakt Bank that is on a different MIDI channel (even if the Cubase MIDI track is set to “1”).
(so, unless you need the above, try removing that parameter, see if it works better… although it shouldn’t be causing any problem as you have it set already).

Other possibility… you have the MIDI track’s MIDI input set to “All MIDI Outputs”. Try setting it to the specific external MIDI keyboard instead.
(I’ll read your original post again tomorrow (bedtime now :wink: ), see if I have missed something obvious.

Thanks Vic. I’m going to bed also so I’ll check back on Monday. Before I’ll try those couple things , particularly the “All Midi Outputs” & see if it helps. I always run that way but I’ll try anything at this point!
Thanks again.
The best—
G.C.