Busted HelpCenter - can't contact support


I’m trying to contact support and it seems like the help center page is broken?


None of the links do anything (i.e the gray boxes: Activation & reactivation, Registration, Contact etc)

I’ve tried Chrome, Firefox, Edge.

Looking at the page source, there’s no href in the links, so I guess there’s supposed to be some JS handling it (why??).

In lieu of that, I have a project file that seems to have been corrupted. I opened it today and get “Invalid project file!”.

The same project’s previous save file is fine, but I don’t really want to have to redo the lost work.
The .bak files for the most recent save are also corrupt.
The previous working save is on the same disk, same directory etc.
Restoring that particular file from remote backup is also corrupt.

Was hoping to ask support if there’s a way to revive them. Any ideas or assistance appreciated.


I fear I cannot be of big help here, but I can confirm that the helpcenter reacts the same for me - on clicking on an area the whole page flashes, nothing else.

I noticed it was not working either, but I did find it on waybackmachine, and the hrefs seem to actually point somewhere there.

Working here in Vivaldi, Chrome and Edge.

What browsers are you using? Do you have browser extensions installed?

Did you turn off javascript?

Restoring corrupted files isn’t possible, they are missing data. The only safeguard here is more frequent version saving.

Just to make sure, I’ve tried Firefox, Vivaldi, Edge on Windows; Chrome, Safari and Firefox on Mac. Javascript on in all of them.

I’ve tried in Incognito windows and with all plugins/ad blocking disabled.

None of them work.

Looking at the page source reveals there’s no href in those links, so they won’t work regardless of browser (unless the intention was to use some janky Javascript, but I don’t get any JS errors in the console at least).

As @rostspik mentioned (thanks!), those links do have an href in the wayback machine snapshot from early October:

Maybe there’s a sketchy CDN edge server somewhere? I’m in Europe if that makes any difference.

In case anyone else needs, the support URL is: https://helpcenter.steinberg.de/hc/en-us/articles/206530864

I have autosave on to save regularly and all those are screwed as well.


If there’s a network issue between you and SB, certainly we can’t troubleshoot here on a user forum, if you cleared your browser cache and the symptom persists, there’s not much else to say here.

Autosave is not what I referred to. I mean doing frequent backups, such as Windows File History, or new version saving from the Cubase File menu.

If you want more answers to the actual question you wanted to ask, I would suggest editing the title of this topic or starting a new one with a meaningful title.

Pretty certain it’s not a network issue, as I receive a 200 HTTP response from https://helpcenter.steinberg.de/hc/en-us just fine.

I can also view https://helpcenter.steinberg.de/hc/en-us/articles/206530864 no problem.

The hrefs in the help center response body are missing, even though the rest of the page content is there. That only really points to a backend issue or some a bad server side cache/CDN issue or something like that (and wayback machine would suggest they should be there, and have been before).

Figured it’s worth highlighting as there’s other people above experiencing the same issue.

No worries on the original issue, I’ll follow up elsewhere cheers.