But I AM running a newer OS X

I used to use Cubase LE 5, then I finally got a new mac. So I ordered Elements 7. I pop in the disc and click on install. The disc runs a system check and says that it can’t install because I need at least OS X 10.6 or higher. But this is a brand new mac and I am running El Capitain… OS X 10.11…
Is anyone familiar with this issue? Know why it thinks I am running an older version?

With just a tiny little bit of research:
https://www.steinberg.net/nc/en/support/knowledgebase_new/show_details/kb_show/mac-os-x-1011-el-capitan-product-compatibility-info.html