C++? - multiple Versions installed?

Hey,

it always wonders me why a couple of plugins are installing C++ 2005 first. Sonnox, Waves etc… Now I do have about 5 Versions of C++ installed on my system. I fear conflicts here. One I was not able to start plugins - till I deinstalled one of those C++ 2005… But I have no clue about that so I do not want to touch the stuff.

What is that? Why is it not possible to just have one single 2005 and one 2008 version? Wouldn’t that be better?

Thanks,

Brandy
C++.jpg