C10.5 Import 'Tracks From Project' limitations

I was excited seeing this feature demoed on the video. Unfortunately the “Import Tracks From Project” feature will not import Activated Outputs on VST Instruments. This was going to be my main use for the feature. Would love to see it in future upgrades. It’s my number #1 request. BTW if I am not performing this correctly maybe someone could help.

that is certainly a PITA.

i did i test. simply arturia spark with some multiple outputs, and first i saw in the poject window not the outputs. yes unfuld the folder and they are, they show up in the mixer, in the right window the activated outputs are correctly activited.

so it seems to work, on windows 10 home btw. do not think it is a windows 7 limitation.

did you check channel settings? i did all with default, so including automation, etc. it was an empty test project. the spark runs with host.

Hi Howl,
Thanks for testing this. I have tried the “Import Tracks From Project” function with both HalSonic and SSD Drums, neither of which import their Vsti’s activated outputs. This is really disappointing. I have a sinking feeling that the feature does not support importing Activated Outputs from VSTi instruments. Not sure why it’s working for you when importing Arturia Spark. Completely frustrated here. :frowning:

i testing yesterday some more, but one of my usb hubs was acting up again (1 in 2 months it does so, why??), so my MCU went down, etc. used other usb ports, everything worked. but i was frustrated, so… why not a personal experience to introduce the following.
now it all works.

i think the difference is this, i can’t get rack instruments with multiple outputs loaded at all… (maschine) strangely… the project i tried is a mess, in the way of use of project window, etc. not a mess as a mix. there is also spark as rack instrument, will not load at all… the track instruments are importent nice… the project was a 9.5 pro project by the way.

it seems it must be track instruments… which is also my preferred scenario, but older projects with multiple outs, i didn’t use that procedure yet, or it was by coincidence.

so my guess; it must be track instruments (not that strange because a rack instrument, o well. why doesn’t it work?).

everyone else notice this behavior? perhaps read the manual, i say to myself…

EDIT: when i check “maschine” and “spark” it only loads the folders, not the plugins themselves… rack instruments they are. strange.

EDIT 2: maybe track import is really “track”, so track instruments.

I tried importing a Track Instrument but still could not import its associated outputs. Not sure how you are getting this to work.

+1. Do that and the feature will be perfect. For Now we’re 80% there. 3rd time lucky!

I totally agree!!!
For me this is an important feature request.

never asked, did you try a specific instrument. because i tried a song/project, using among others maschine that crashed in 10.5, but i could import one of the tracks, with multiple outputs. (the project i loaded in 10, worked, resaved it, then it worked in 10.5 resaved in 10.5. or it was a quirck or how you call it english…)
but the main thing, it seems to work for me. accept when it is loaded as a rack instrument…

i only tried maschine and spark, because they are the only one which i use with multiple outputs.

for spark i created a special project witin 10.5, did i mentioned that? because most of the times it was a rack instrument, which for me isn’t the way, looking back, the only special templete i have made was for spark, 16 out… as a rack, but it lacks overview and other things i can’t remember now. problably more workflow related, and what i like.

did you try a new project?

Hi howl. I did try this using track instrument as well with no luck. The vsti instruments I tried this on were Steven slate drums version 4 and on halion.

I think the feature is unavailable to import the activated outputs of VST Instruments. It would be high on my list for future upgrades. A real time-saver.