C10 with Arturia V-Collection HiDPI error

I yesterday installed Arturia´s V-Collection which seems not to work in Hidpi. Is there a solution for this?
Plugin loads, but displays only part of the plugin. When pressing a key for example a different key gets triggered.
Same for any other functions in the plugin.

Works ok for me, try rescailing the arturia plugin. but I’m on windows not sure about yourself.

How to rescale? Cannot drag form the corners… Sorry, I am stuck :slight_smile:

Yes, I am on Win10pro 64 1809 as well.
MSI MEG X399 Creation Gaming Mainboard S
AMD Ryzen Threadripper 2950X - 16x 3.50G
Gigabyte GeForce GTX 1080 Windforce OC 8
G.Skill Sniper X DDR4 32GB
SSD Samsung 860 EVO 2TB SATA3, 550/520MBs
NAS Qnap TS253A 2x10TB

I had this issue with Arturia even before Cubase 10. It’s for sure not cause HiDPi setting

try this:

  1. Go to the concerned plugin folder: C:\ProgramData\Arturia<product name>

  2. Select the concerned product and open it’s “tmp” folder

  3. Once you are in the temp folder, you will see numerous files.
    •Delete all of the files.

this will reset your plug-in’s preferences and potentially solve your issue. - Restart cubase and test the plugin.

-else- try :

uninstall and reinstall clean:

  • First go to: C:\ProgramData\Arturia

Delete the concerned product folder

  • Then go to this folder:
    64-bits: C:\Program Files\Arturia<concerned product>
    32-bits: C:\Program Files (x86)\Arturia<concerned product>
  • Click on the uninstaller

Once the uninstall procedure has been completed, you can reinstall the concerned plugins directly from the Arturia Software Center, or from this page: https://www.arturia.com/v-collection/resources


p.s. the VST screen size adjuster is on the top left side (when you click on the arturia symbol) - It is not visible with your current weird GUI - should be fine after you clean prefs and/or reinstall

Looks like there might be a problem see here from Arturias forum


@Aurosonic But without HiDPI its working fine. Maybe somebody can explain me how to scale plugin windows. Maybe that is what I do not get in my head :slight_smile:

OK, @peachy from the last message there it sounds like a bug to be repaired…sometime… But why does it work on your machine then?

FOUND the hidden rezise function but it changes the size of the part and does not show the whole plugin surface
Now I am reinstalling the whole bunch by Arturia Software center which will take another half day…

you may not have the folder properties as “visible” - it’s a special folder…

copy this:


into your Windows file explorer address bar and press enter

Beats me m8, I have a very big monitor… ?
To be honest its rare I would actually run an Arturia plugin directly in Cubase I would usually wrap in Komplete Kontrol, I just did that test for you on one plugin, but even KK has issues with cutting the Arturia plugins GUI. Their habit of using overly large artistic representations of classic kit might sell products but I don’t find their GUIs very good at all, they install way to much graphic content on the C drive and I don’t find it pleasant program. Good for preset browsing and showing to your friends, but ultimatly a bit frustrating if you are not faniliar with the original device. I like the SEM and the DX7 is a step in the right direction but you could land a Jumbo on the Jupiter GUI and still not be able to see the filter control swiftly.

they are all working fine here… without any wrapper…
(win7x64 btw)

@peachy -I agree that all Plugin devs (if possible) should use vector graphics so that plugins gfx can be kept a small data size and the GUI can be resized (by click/drag) as much as needed without losing resolution …

I like the plugs… yes, some are very complex- but you will learn how to use them over time (if you want to do so) - If I ever stand in front of the real deal, I will feel right at home then… - same with all these modelled processors etc…
for example: I don’t know if I will ever own a synclavier or whatever(or feel the need to own …) - but If that gear would sit in front of me, or, I would rent some super special boutique gear for some hypothetical super session, I would know what to do…
Anyway, I do not get things to “show friends”… These are all just tools for the sound… - But why am I tellilng you this if you indeed have 30yrs experience?:wink:

  • Just map the filter or whatever to the quick controls;)

Newly installed does not solve the problem. HiDPI definitely does not work with V Collection

Does it look good if you deactivate HiDPI?

also, found this good read if you(or whoever) haven’t seen it yet:


I also stumled across this post from someone@kvr- not about cubase but hidpi and plugins…:

I will retract myself from this post now… (dont use win10 or hdpi so I can’t help you there with troubleshooting;) )

pls let us know how things go and what the solution was;)

good luck=)

@ Oscar

I hear you, which is why I use KK to wrap the plugin, the filter is right in front of me, and I did not mean to imply you personaly showed them to your friends. :slight_smile:

I just like having a good whinge now and again, and seeing as I have a day off to sit in front of my PC I thought I would indulge in my favourite habit of instructing developers how to build a decent plugin… Come on we have all done a bit that :smiley:

I really don’t mind the Atruria stuff I wouldn’t have bought them otherwise, but the GUIs are a bit of a bug bear with me, I would rather use a u-he plugin anytime, although its not exactly the same.

@Oscar Goldmann
As written further above, without HiDPI things work.
Helpcenter did not show a solution, nor kvraudio Link.
I also have send the question to Arturia Support. If I had paid he full price now for VCollection, I would be really go mad.

Of course, once this is solved, I will post feedback here as many times I found solutions the same way when somebody else found out before :slight_smile:

If you have not tried this set windows scaling to 200% exactly. Steinberg rounds for example 150% to 200% but the Arturia might be at 150% which might cause this issue. I can’t try it cause I have no HDPI monitor yet.

makes sense… :wink: oh, btw, did you see this plugin i have ? flaunts random vst uhuh… you know whats up;)

ah yes… thats very sporting of you:P- I also do the same to vst devs and also some sequencer devs:P :wink:

It can get “fiddly” I must admit… having to lean forward, all close to the screen to somewhat catch a glimpse of what some miniature words say is more relevant nowadays than ever… cant remember such “fine print” synths in the past… even figuring out what module I am inserting from modular for example…lol its not always a walk in the park… my small laptop monitor isn’t an imax;)
heck man (no pun intended) - I would prefer the real analog deals over their digital “homages” anyday - but I must admit… I feel like I am in heaven with the ergonomics of vsts alone… - no more lists with synth patch numbers, no more jazz drives, no more akai samplers no more this, no more that…
save project with vsts, done. great =) lol its wonderful=)

@wabo cool, hope you get it sorted… thanks in advance for the “solution” feedback (If you can remember to post and have time etc;) ) Sounds like something good to know…

carpe diem=)

Next step reached.
Windows Screen Setting at 100%, HiDPI on, works for Arturia, but then Cubase menues are extremely tiny, partially as one can see on the attched picture.
Any other windows setting does not work. I am used to have it set at 125-150% so I can read the menues.

HiDPI off, Windows Setting at whatever(tested 100-225%), Arturia Plugins work but waste a lot of space. Cubase gets a little blurry then.

So OK, one can use V-Collection, but not together with HiDPI other than 100% and with unreadable menues.
I believe that the problem, if there is one, should be solved either at Arturia for full functionality of the collection or Cubase for full compatibility of VST´s on the market. Especially the HiDPI setting would have saved me from wearing glasses all the time or turn up contrast and brightness on my monitors.

At this point cubase only supports full integers scaling. So 100% 200% etc. Did you try 200%? Cubase will look the same as at 150% but arturia might scale correctly then!