C11 download assistant trouble

licence purchased, download assistant updated: assistant asks to sign in>> which opens browser to sign in, which i do. message:

Authorize Steinberg Download Assistant
To authorize Steinberg Download Assistant, you must allow your browser to open Steinberg Download Assistant. Once authorization is completed, you can close this page and continue working with Steinberg Download Assistant.

that’s where it’s stuck. the download assistant only opens to the sign-in page, which leads to the same cycle of signing in etc.

Same issue!!!

Same here!

Here I come to the party! Any news on this?

For Steinberg folks: it’s so frustrating buying software and cannot install it after four days… Can we get some help on this?

I’ve also opened a ticket to the support center, but no answer until today.

I got the same problem over here.
Paid 99 euro and nothing happens when I want to download it.
Pls help me

honestly I don’t remember the exact way to do it because I did it when the servers were kneeling down and it was a lot of confusion/frustration.

but I think you need to differ between download access code and activation code.

I solved my issue by making sure that the computer clock was synced and then it worked straight away.

Windows > Settings > Time and Language > the press the Sync button

Hope that works

1 Like

Same problem as the OP here. Have tried various solutions including those shown in the previous post(s). Download Assistant will work on my MacBook running Safari but not my Windows 10 desktop. Grr…

Removed Malware Bytes on my PC and it’s finally working! Check your AV / Anti-malware software!

Glad that seemed to work. I did not remove Malwarebytes from my machine, but I did disable all aspects of it. Unfortunately it didn’t change SDA ‘s behavior. On a different machine, I left Malwarebytes operating. SDA worked correctly just one time at that point. But restarting downloads later, SDA didn’t work.

What seemed to work for me was connecting with Steinberg.net chat and getting a link from them. Unfortunately for some outside the US that didn’t even work.

This from Mathias Quellman:

https://www.steinberg.net/forums/viewtopic.php?f=307&t=202314

Please can we keep things on topic? This message above here is about activating licenses, but this thread is about downloading Cubase 11 via Steinberg Download Assistant. This is a problem specific to Windows users, I don’t think posting out topics messages can help users (like me) that are struggling to download the software they purchased.

I finally managed to start SDA, I still don’t think it’s a matter of disabling anti-malware/antivirus, since I tried by disabling everything (I’m talking about Windows Defender, I don’t have Malware bytes) and the behaviour was exactly the same, at least with Chrome and Firefox as default browser.
It worked by setting Edge as default browser, after playing with defender settings. I can assure that the past days I already tried Edge without success, so it might be I’ve touched something right on the firewall side.
What I know is that now the Defender/firewall/anti-malware is active (I restored all the options) and I’ve Edge as default browser, with this in place I’m able to start SDA.
Still waiting an official answer to my two opened issues from Steinberg.

Thought maybe both issues were stemming from the same server problem. Not meaning to lead anyone down the wrong path.

INCREDIBLE!
that was precisely the issue !!

thank you very much for reporting

My pleasure as someone suggested it to me.

Download assistant wouldn’t even download. No error…just a quick change on the tab title. And no difference after synching or changing time server.
However, it worked instantly when I switched from Chrome to Edge.

Thanks!

unacceptable

Adding to this topic: I’m on a Mac, and I have no antivirus installed, The clock is synchronized. Yet, I have the same issue (no way to authorize Download Assistant).

Paolo