C13 Pro Upgrade bug: Lost key commands

Opening in C13 Pro a project I’d been working on in C12 Pro, and I’ve lost all my key command settings. I don’t see any way to import them from C12. Please tell me I won’t have to re-add them all back manually!

Cubase 12.0.70 on macOS 13.6.1 Intel

It should migrate automatically but sometimes in some setups it doesn’t. Worst case, you can always copy the various files from the C12 folders in appdata to the corresponding C13 folder.

But since you have Pro, just launch C12 and save your user profile to a file. Then in C13 load that profile. The manual should have better directions.

EDIT
Opps, just noticed you’re on Mac. Appdata is for PC, don’t know what that corresponds to on Mac.

Me neither! I did launch C12 and saved the preset, although it doesn’t give me the option of saving to a specific file. Then in C13, it doesn’t list the preset in the list of load preset options, so it must be hiding in a file location that only C12 knows.

I don’t think Export Key Commands is helpful because there’s no corresponding way to Import Key Commands afaict.

I wonder where on the mac, C12 saves its key command presets?

Don’t save a preset of the settings, save a user profile. It exports as a file to anywhere you want. Then import that in Cubase 13.

I’m on Nuendo so it may be different in Cubase, but I think its under Edit > Profile Manager (not at my pc right now, but its something like that)

This doesn’t work. I exported a profile in Cubase 12 Pro, then imported that profile into Cubase 13 Pro, but the key command mappings didn’t transfer over.

I filed a Support case with Steinberg and will follow up when I have a solution.

Steinberg has not been helpful at all unfortunately. What it looks like is that Cubase 13 Pro moved many of the key commands I had custom bindings to, and the XML file is incompatible. So all my key commands have to be manually reproduced. What a bummer.

I have exact the same problem. Lost all my key commands after trying to import them to Cubase 13 PRO. I bought the Cubase 13 PRO but returned it in the end. For now I stay with my C 12 Pro until they solve the problem.

Hi, did you solved it? I have the same problem like you…

No solution. I’m told if I add the tag issue then this might get some eyes from Steinberg. I’m updating to Cubase 13.0.20 now, so we’ll see if they’ve addressed the problem there.

I can confirm that the bug is still there in 13.0.20. I copied the Key Commands.xml file from my Cubase 12 preference folder over to Cubase 13, and started Cubase 13. My key command bindings are missing.

I finally gave up and just manually went through my CP12 Key Commands.xml file. I opened the file in Emacs and searched for name="Key" and then for each of those, verified the CP13 binding for that command name. Many of the command names have changed between CP12 and CP13, but I think the only one that did not get copied over was Transport - Return to Start Position on Stop. So I set that one manually, and will now continue to work with CP13.

hiya pumpichank! can you kindly tell me how you verify the CP13 bindings on each of those files? thanks!

I just suddenly lost it yesterday, after a long time it was usable, since Cubase 13 released.
I thought it was my mistake (somehow). Luckily I still have a backup key commands template which save in another folder.
I copied it to the current Cubase 13 template and it works again.

I did it with a combination of Emacs (a text editor) and CP13’s Key Command window. What I surmise is that the XML file has a attribute called name="Key" for any of my custom key commands. I think that’s there for some or all of Cubase’s built in bindings, but thankfully it wasn’t too many and it definitely wasn’t all key commands. So I just scanned the CP12 file manually looking for that string, then tried to find the same command in CP13’s Key Command window and cross checked that they were the same. Where it was missing I just added it to CP13 manually. It took maybe 45 minutes.

I’m now thinking that the CP12->CP13 upgrade process just missed this command, probably because it was renamed between those two versions. I’m chalking it up to Just A Bug.

Thanks very much for your explanation, much appreciated!

1 Like

Typicall Steinberg. How many Years this Problem exists!? Thats uncredible!! fgffg

Any news? I still using Cubase 12 and wont using the new Cubase 13 until i can safely transfer all my Key commands from C12 to C13. I have planty of them. Is this issue solved with the newest Cubas 13 update?

I ended up reviewing and restoring them all one-by-one. It was pain but ultimately only took an hour, which was less time than I spent angsting and posting about it :stuck_out_tongue_winking_eye: