C13 Snap to Grid in MIDI Key Editor not working for note lengths

Snap to Grid is switched on. Grid is set to 16ths, and is showing 16ths, but re-drawing the end of notes is snapping to 8ths.

Hey. Could you please confirm that both the global and editors snaps are aligned in their views?

Yes they are - both set to 1/16 and remain in sync if I change one or the other.

Hmmm. C13. Try a shutdown restart. So far all my issues encountered with snap or graphical glitches repair after restart. Let me know how you go

Makes no difference. I get the same problem on two different PCs,.

Can you check this setting in the Key Editor?
grafik

Use Qunatize should yield the result that you want. Adapt to Zoom not.

I’ve tried both of those settings. Makes no difference.

The possible note length is determined by the setting in the Length field.
grafik

Quantizing the end of the note to the grid is done by “Quantize Ends”
grafik

You can assign a key command to this function, if you need it often.

Have you already ruled out prefs problems by starting in Cubase Safe Mode with disabled preferences?

Quantize note length makes no difference. I’m not quantizing note lengths - I’m drawing (dragging the end of the note) the length of a note with the mouse.

Steve:
Gave it a try - makes no difference.

And if the Length field is set to 1/16th you can draw lengths that are not 1/16th or multiples thereof?

Can you make a screenshot of these toolbar settings? Since others cannot repro, we need to rule out user error, or other unexpected factor.
reload to see animation:
vid1

Mea culpa. I was setting Quantise instead of Length Quantise. All good now.