C6 Mac - first experiences

Well finally got my cardboard box today containing (of interest) a piece of paper with a number on it and a single DVD with C6 on it in a 300Mb folder. Some demo DVDs but what’s the point.

Install was ~7GB from single DVD.

Installed ok, but would not start with certain plugins installed (just hangs requiring a force quit).

Eventually got it to load after removing the plugins where it was hanging. Conveniently they are the ones that are displayed while loading as it freezes.

Tried to load up the last project I was working on with 5.5 - hangs at loading my Virus|Powercore plugin. Just doesn’t work.

I can create a new project and create an instance of the Virus|Powercore, no problem, but old project will not load up.

Experimented with the 64bit version (on OSX, Get Info, untick ‘32bit’) - wouldn’t load as soon as it hit ‘Tonic’ (a PPC plugin). I know there were noises made about ‘not supporting’ some older plugins, but I see that basically translates to ‘freezes and will not load requiring plugins to be uninstalled’.

Not impressed. :neutral_face:

Fitz I’m currently a PC user but have you managed to get all the VST 2.4 TC Powercore plugins operational?

That’s discouraging. Obviously, it means setting up completely different plug in folders for C5 and C6.
On the plus side, I did figure anything I did in 64 bit would have to be started from scratch.

Fitz-speak to us of timestretch, please??

What’s to be discouraging NYC?

He was testing using plugins when the true test is how it works natively, ie with all the included steinberg plugs and any that conform to VST 2.4 and above.

It was discouraging for the reason I stated, and also that it FREEZES rather than skipping the plug-ins, but really, let me clarify:

it was discouraging to me.

Better?

Not had time for proper testing yet - will be experimenting more tonight.

I’ll have a test later.

I suspect using new projects will be fine though.

Can you say which plug-ins?

Aloha and tanx for the info fitz.


{’-’}

I made the huge mistake as a Mac user with jumping on Cubase 5 way too early.
I certainly wont make the same mistake with Cubase 6. I’ll wait for at least 2 updates this times.

I booted C6 for the first time yesterday. Plugs all loaded except the old Halion OEM which I think was the demo for HSO from the C5 bundle.

Question: Why does Cubase respond to a missing authorisation to Steinberg Plugs only by crashing out? Why can’t it just bypass them? this has bugged me for years.

I wanted to try the new Tempo detection.

Reasonably impressed that it managed to identify the basic beats of the first tune I tried (Stereo file of a soul track) but it got the tempo doubled (easy to halve the tempo). Harder to understand why it defaults to ONE beat in the bar - the manual just states that it always does this “…can easily changed later” which is true, but why not accept a default user setting, or default to 4/4, which must include 90% of all songs in the West…

On the whole though, a useful trick.

Will try the multi track drum editing next…

Reaktor 4 and it’s FX (which seeing as I have Reaktor 5 I don’t really need anyway) - and some SSL utility plugins.

Also had to move out the old Virtual Guitarist (v1) - PPC and Vokator (Intel, but Carbon).

Trying to load C6 x64 day 2.

Today it did not freeze on Tonic, (perhaps it did as it is supposed to, and simply blacklisted it).

The display on my monitor however has dimmed except for the title bar of the Console which appears whenever the Powercore has issues.

One wonders if it is a coincidence that as C6 starts shipping, TC Electronic washes their hands of the Powercore.

Wait… could it be? It’s LOADED…? Did I accidentally set 32 bit mode again? Activity monitor says 64bit…

Wonder what actually works?

Hookay… in 64bit mode, and basically 32bit plugins are going to be bridged (fair enough) but they look like this -

Powercore ClassicVerb:

Clicking it produces the GUI fixed in the middle of the screen:

(Can’t drag that).

Battery 3:

Again, clicking it launches the GUI.

…which is going to be a bit… awkward.

Overall Cubase 64 does feel ‘snappier’ though, but I haven’t played with 32bit version much yet.

As suspected the transition to x64 is going to be PPC->Intel all over again. Better get your credit cards paid off as we are going to have to buy our studios again if we want x64.

Managed to get a (basic) old project loaded under 64bit mode.

Pressed play and instant total ASIO overload, unusable; think it’s the SSL Duende causing problems. Same project works fine under 32 bit.

Looking forward to being able to work in 64bit, but I think that’s going to be a while off.

Fitz-You know, FWIW, I never really assumed I was going to be able to open 32 bit C5 projects in 64 bit C6 without substantial pain. Did you?

p.s.-what, no 10.6.6/AppStore? (heh)

p.p.s- t-i-m-e-s-t-r-e-t-c-h-?-? p-l-e-a-s-e-?-?

Fitz, are you using a PCIe or 1394 Duende can I ask please?

‘Open’, sure…

As Cubase doesn’t install any kexts (to my knowledge) then it could feasibly be delivered over the App Store. Might run foul of Apple’s ‘no bugs’ policy though…

oops I forgot - do you have a particular test you want me to do…?

I have a Duende ‘Classic’ connected to it’s own Ti chipset Firewire card with all plugs except the reverb.

Ok, so are you running 3.5.2?