C8.5 Staff "No Accidentals" does not ignore accidentals

Tested in Cubase 8.5 x64.

In score edit we used the symbol palette to set the entire project in Eb (Key changes for entire project set switched on). This works great for every instrument except for some percussion staffs which should be managed by their drum map and display notes as defined in drum map setup. For those staffs the “Use score drum map” has been switched on and also the “No accidentals” flag.


  • The drum score still shows 3 flats at the beginning of each line.
  • Accidentals all over the place. Need to switch them off one by one. For instance when hi tom should be displayed as midi note E4.

Please make “No Accidentals” do what it says it does.

Unable to reproduce here, “No Accidentals” makes them all disappear.

Key signatures are not suppressed via the the No Accidentals checkbox, since they are not accidentals.

You can hide key sigs for a particular layout using the “Real Book” checkbox in the Layouts tab of Score Settings.

To have different key sigs on different staves uncheck Key Sigs for entire project. Also, you can hide the initial key sig on the staff in question.

The “real book” check seems a good way to get around the key signature thing, thanks for the tip.(could do all hiding again when the layout changed the number of bars in a staff).
I still got the accidental thing when i find the time i’ll upload a demo project somewhere.