C9 vs C8.5 Stability

Welp. I decided to upgrade from 8.5 to 9.0.1, after all.

Is it too much to ask to have a shiny new Cubase update, oh, I don’t know, simply load a project without crashing?

Every single upgrade I go through this. Not once has Cubase “just worked.”

I know, I know. It’s not Cubase, it’s a plugin. I know the drill.

Still, as the inventors of the VST spec, it would be nice to see a highly robust implementation that can load a project, even with offending plugins.

The Sentinel is the first baby step toward a true memory / thread protected approach.

I prepared so well, too.

I reorganized my project in 8.5 and bounced all the VSTis down, removed them all and moved my VSTis to another machine to trigger remotely, upgrade all my plugins to latest, removed all my 32 bit plugins and even removed some older 64-bit plugins that were long in the tooth. Sentinel only blacklisted a couple plugins, that are not used in my recent projects and I even removed those. Zero blacklisted plugins…

My 8.5 projects still won’t load :laughing:

Of all the DAWs I own, Cubase is the only one that consistently fails to load my projects when upgrading.

Not a good first impression of v9, but also was not unexpected :confused:

Now the fun process of dragging off the rest of my plugins until I find the culprit(s) begins…

Honestly, the only reason I’m staying on the Cubase train at this point is because of my CMC controller modules. I love them so much. I’m too lazy to finish my Bome MIDI Translator project that will alllow it to be used in other DAWs.

Fresh install and I’m already trashing prefs. Not a good sign.

But I finally got my project to load after removing nearly all my plugins.

Spent 10 minutes getting windows re-positioned, console widths set, etc. and it crashed right as I was about to save. Hadn’t even pressed play yet, or even opened a single plugin.

And after a reboot, now it won’t even reload the same project that did finally load.

Not looking good.

So, here’s an update.

I trashed my Cubase 9 prefs and started over with a clean slate. I’ve recreated my template in Cubase 9, and so far so good. Everything seems to be stable now.

Do we really have to go through this at every update?

To sum up, my 8.5 projects still do not behave well in 9. I get frequent crashes. New projects started in 9 (with fresh preferences) seem to work and remain stable (2 days in so far).

That’s what I’m experiencing too. However, unlike you, I never had crash issues with older project before.

Here’s my update, too… I was able to “recover” the core of my project by temporarily renaming all my plugin folders (disabling them). The project then loaded and didn’t crash. I then removed all the plugin instances in the entire project, resaved and then renamed my plugin folders back to normal.

So far, this recovered, plugin-less v8.5 project seems to be stable in v9, but I have not tested stability very robustly yet.

I’ll be adding plugins back in as sparely and carefully as possible. Also, I’m going to try to use stock plugins as much as possible.

And no more VSTis are allowed in my project ever again. I’ve changed my workflow. I’ll be triggering them on a separate DAW and recording the result, only. Either using VEP or over optical cables and then manually trimming for timing.

Update 2: Cubase is now on ice until a future update fixes some issues for me. I’m back to Studio One :cry: No crashes, but sluggish graphics, poor ASIO performance and several UI niggles that I just don’t have the patience for.

Wow… Cubase really doesn’t like you. I’ve no idea why you’re experiencing those issues.

Wow. I understand yer frustrated right now, but that just seems like wearing a raincoat… on top of a condom. :smiley:

Yup :laughing: Very true.

Full disclosure, the reason is many-fold, not just reactionary: Studio One, which is still my primary DAW right now, had some major issues with crashing during unfreezing VSTis and I was forced into this approach (and haven’t had time to see if it was properly fixed in more recent versions). So, I’m sharing the workflow with Cubase even though it’s not required as strongly.

Also, because it fits with my workflow of my hardware synthesizers.

Also, because I’m finding recordings to be tighter (no phase issues).

And because it solves the real-time playback / latency challenge, since this “real-time” daw can be set to a very low, playable latency and allow my main “mixing” daw to have a higher latency.

Also, there is something nice about the decoupling and reusability of this separate computer as a “VST instrument rack” that survives reboots of my main daw.

And, I’m finding the increase in horsepower, because it’s a dedicated computer just for instruments, allows me more creative freedom with the effects I add post VSTi. In other words, I can get closer to my mastered sound from the get-go and that means less peak taming and stuff in my main daw. Along with this, is a consistency in the k-metering and tone I get across many VSTis, since they share a common buss before I record it.

Finally, having this playable low-latency daw always at the ready, I find inspiring and can play an idea (like with a hardware synth that is always at the ready) even when my main daw isn’t loaded up.

Oh, and because Cubase is such a slow project loader, this helps cut down on that time.

Have you tried “Save New Version”? Old version remains “My Song” and new version becomes “My Song-01”.
See if the New Version is more stable than working with the original version.

It was mostly for issues with Studio One crashing during VSTi unfreezing (but also Cubase now with the v9 migration issues).

I, admittedly, use more plugins than most. :laughing:

I’m pretty sure that’s identical to a “save as” just with the convenience of auto-renaming it. In other words, it doesn’t work like Studio One’s (horrid, imo) “version control” framework.

Jalcide, do you have crash dumps to send over?
Steve, same for you in case you experience issues again.

Thanks!

Thanks again, Fabio. Will do.

Btw, I tried getting the crash dumps, but for some reason one of the parent folders said I didn’t have permission (even though I have full admin rights and am the only user on this computer).

I know how to fix this, but decided not to mess with permissions, or do that “take ownership” trick, since I have a somewhat stable/workable situation going on in v9, at the moment. I need to finish some music before I make any changes to this computer :smiley:

Cubase stores the dumps in Documents -> Steinberg -> Crash Dumps, you should not see anything like that.
The Documents folder is in your user’s folder path, hope you don’t really get a permission message here? :astonished:

I didn’t see the Steinberg folder in my main, logged in user account: C:\Users\jalcide\Documents

Or in: C:\Users\Default\Documents

Or in Windows’ “Documents” shortcut

The other choice I have is: "C:\Users\All Users\Documents (which is a mysterious shortcut to somewhere else) and that, sadly, is where I don’t have permissions. So, if it’s behind there, I’ll need to change permissions on that destination folder (wherever it points).

That’s not right if you are logged as ‘jalcide’. There must be a C:\Users\jalcide\Documents\Steinberg folder, it’s created when you install any version of Cubase. It is a shared folder, so even if something went wrong when installing C9, it should be there.
If you are working on a project and can get the job done, please do, but we should indeed have a look at that when possible.

I liked the new version 9 when I first installed it, but when I started my first major session with it I got issues with VST plugin inserts (nothing to do with 32bit or sentinel , the issue is in the Bug forum) and I was spending so long trying to sort it, I’ve had to roll back to 8.5. Just to get some work done.
Disappointed right now.

that had happened a lot here too

Could still be a plugin. With saving, the plugin is requested its settings. Or does a normal save work?

9.01 is much less stable for me than 8.5 on Mac El Capitan.

8.5 is no picnic either, sudden crashes when using the file dialog to perform the most basic tasks of importing or exporting, but c9 is even worse. The easiest way to crash either 8.5 or 9.01 is to choose “import audio from video file” - instant crash before the file dialog even opens. As I work with video as part of my daily job this is extremely frustrating.

Along with the frequent video engine lock-ups I’m actively trialling other DAWs to replace cubase at this point.