Can anyone explain this crazy train wreck of a score? :-)...


I’ve filtered all frame and system breaks (if there were any) and deleted. I was entering music into a simple trombone part in Galley and didn’t notice this until I switched to Page View for the first time. Any suggestions for how to “undo” this? I’ve turned off any sort of 4 bars/system or systems/page sort of setting in Layout Options…

Thanks for any help (!)

  • D.D.

First thing to try is reboot your computer. Sometimes Dorico gets into some weird mode.

The solution seemed to be to insert a random system break somewhere - this broke the weird formatting and I could further edit as per usual. Still curious what caused this, though as it was pretty alarming :slight_smile:

  • D.D.

I’ve come across this a few times. Every time it’s happened it’s been as a consequence of deleting system or frame breaks. I either undo what I’ve just done or do exactly what you’ve said - insert a system break somewhere and that seems to sort it out.

The chances are that at some point you used “Make into System” or “Make into Frame”. What these functions actually do is add two breaks, where the first is instructed to “wait for next” in the properties panel. If you delete the second break, the first break is going to continue squishing music onto the system until it reaches either another Break or the end of the Flow.

The solution in these situations is to turn on your Break signposts, select the one at the start of the troublesome system, and unset its “Wait for next” property. This will allow Dorico to reflow the music automatically.

Perfect explanation - thanks Leo.

Thanks! - however (as I mentioned in my original post), that was the first thing I actually tried and it didn’t do anything. However, when I subsequently inserted a system break some where it for some reason solved the problem and reset itself.
Best!
D.D.

My suspicion (and it really is a 99.9% suspicion) is that you didn’t actually turn on View > Signposts > Frame Breaks/System Breaks. You can’t filter things that you can’t see, even if you Select All first.

I have seen variations on this situation many times, both in my own work and in projects that people have posted on this forum. It has always been either:
a) a Break that has the “Wait for next” property set (with the subsequent Break deleted) or
b) inadvertent deletion of music that has a “Starts/Ends Voice” property, resulting in a staff that has no primary voice

I’m sufficiently passionate about this that I persuaded the team to add a note at the bottoms of https://steinberg.help/dorico_pro/v2/en/dorico/topics/engrave_mode/engrave_mode_systems_making_from_selection_t.html?hl=make%2Csystem and https://steinberg.help/dorico_pro/v2/en/dorico/topics/engrave_mode/engrave_mode_frames_making_from_selection_t.html explaining what “Make Into System” and “Make Into Frame” actually do.

(DanKreider, if you happen to read this, this is a prime example of why I don’t recommend the “Make Into” buttons :wink:)

I definitely chose the key command I made for “view all signposts” and then chose “filter system/frame breaks“ and hit delete (even though there didn’t appear to be any visible, though it was hard to be sure with the score so crazily bunched up). However, inserting a single system break seemed to solve the problem (though I’m not sure why).
Best -
D.D.

There’s no such shortcut as “View All Signposts”. There’s a toggle for “Hide All Signposts” but that doesn’t show all signposts - it just shows the ones that were previously ticked in the list, where you’ve previously used “Hide All Signposts” to hide all the ones that weren’t already unticked.

If your signpost list looks like this, then hitting your “Hide All Signposts” shortcut a million times is never going to result in System Breaks or Frame Breaks being shown:

With that in mind, is there any chance that you didn’t actually turn on All Break Signposts, and as such, you didn’t select them, filter them or delete them?

The fact that inserting a system break “fixed” the problem would indicate that either it’s the usual problem that I’ve been banging on about for ages, or it’s something that nobody has ever reported on this forum. I’m not a betting man, but if I were, you know which way I’d be betting :wink:

I have that OP’'s situation come up all the time. System breaks and frame breaks are a real mess. You can set them perfectly and then change something on another flow and the original frame break will be completely distorted. And another really horrible result that can happen here is that systems can get OUT OF ORDER. In other words the system with measures 10-14 can end up above the system with measures 7-9. That should NEVER be possible under any circumstances, even if the casting off process requires staffs to be crowded or overlapped. You must not allow staffs to get out of order. It is way too easy to miss that when doing the final edit of parts, and that becomes a disaster in rehearsal or performance. I will attach a video showing some of these situations.

See https://app.box.com/s/8lrw73d8x7zcmvlox675wp27q5cdacdh

The only reason this could be happening is because you’ve manually adjusted the vertical position of all of the systems in that flow, and the vertical spacing adjustment is being cleaned up when the bar at the start of the system changes (the spacing adjustments only apply as long as the bar at the start of the system remains the same: it’s OK for a bar to drop off the end of the system, but if the bar at the start of the system changes, the adjustment will be lost).

If you’re having to manually adjust the vertical position of every staff in the frame, then you’re doing something in a sub-optimal way. If you want a larger gap at the top of a music frame, then either use the option on the Page Setup page of Layout Options to increase the music frame top margin, or if you want to override it on a per-frame basis, select the frame and use the Properties panel to override the top margin. Alternatively, you might prefer using a master page layout in which the music frame starts a bit further down the page. And if, having made the top system start further down the frame/page, you find that the distance between subsequent systems is too small, adjust the options on the Vertical Spacing page of Layout Options to put more space between them.

System and frame breaks are not a real mess in Dorico, but certainly you can make a real mess if you make a lot of manual adjustments. At the very least I would suggest only making vertical spacing adjustments once you are satisfied with the casting off.

I can’t view the video in your link unless I BUY a new codec “HEVC video extensions” from the Microsoft store, and I’m not going to waste money on that.

(Or possibly, the video is malware and it’s not going to send me to the Microsoft store at all…)

There are plenty of video formats that work for free!

Also, it’s not “really hard to unjumble this mess”. Select any red squares and hit Delete or Backspace. If you can’t get hold of them individually, drag a marquee selection around any red squares (including some blue ones, too, if that’s easiest) and hit Delete or Backspace. That’ll reset those staves back to their defaults.

Probably so.

On this project, I found that some of the pages started with a reasonable margin at the top, but others – those that had some of the collision stacking issues we discussed on another thread, encroached on the margins. So certainly, I had to to move those manually. Regardless, I would have thought it would be illegal to have staffs ever be out of order.

There is something seriously broken here, and I do not accept that it is my fault.

Please see the “before” picture below. This is a part layout spaced almost as I want to see it. Yes, I have used frame breaks, system breaks, and manual staff positioning – but that’s because this is how I wanted the part to look. It really isn’t anything even slightly exotic.

The only change I need from here is that I would like measure 51 to start on a new staff, and that should push measures to cause the last staff to be a full line. But when I insert the system break at 51, I get thee same kind of train wreck the OP describes. See the “after” picture. The two staffs seem to be completely superimposed. And that creates the catch-22 that you cannot select either of the staves to manually move them. I can’t fix this. All I can do is undo to get back to the point that the staves are separately visible and draggable.

How can it ever be considered valid for a staff to overlap, or worse yet, appear out of sequence?

See the “correct” image below. I was able to get the desired output, but only by undoing all the layout actions, back to the manual staff movement. I put the system breaks in first, which is not obvious because you may know where you want the system breaks until after you have manually moved staves to balance the page. After inserting all the system breaks, I was then able to to the manual placement of staves. But doing it the other way around creates a real mess.

IMHO, the program should never overlap staves and should never display staves out of sequence. That would make it clear what is going on and allow any of the staves to be dragged as needed.



What happens if you turn on Staff Spacing in Engrave Mode? Do you get red squares? Can you marquee select them and hit delete?

I am trying to recreate that situation. It appears that on my first attempt I just “got lucky” and had the staff positioned such that the system break caused the two staves to be completely superimposed. In that case, I don’t think I could delete the manual positioning. Maybe I could, but I think I tried that. In my attempts to recreate, the staffs are overlapped, and out of sequence. But because they don’t coincide completely, I can select the handles separately and remove positioning. But that puts EVERYTHING out of order. Basically the only thing that works is to get rid of ALL staff positioning before adding any system breaks.

The reason inserting system breaks has an impact on the staff spacing is that the adjustments are saved relative to the rhythmic position that begins the system where you apply the adjustment. If a system that has an adjustment is changed such that it now starts with another bar, that adjustment is removed. Dorico doesn’t go around removing other adjustments you’ve made – you would instantly cry foul if it did, and complain that the program was interfering with your choices and getting in your way. So it makes the smallest adjustment it can make: the adjustment to that system is not valid, because that system doesn’t exist any more, so it is removed.

Please allow me to reiterate that if you are finding that you need to make sufficiently large adjustments to the position of a system that when that adjustment is removed it causes the system to overprint another system, there’s something else at play. You should never need to make a large adjustment like that if you have the vertical justification and ideal vertical gaps settings set appropriately on the Vertical Spacing page of Layout Options.

With no disrespect intended, I don’t think you understand the situation here. There are various quirks of Dorico behavior that indeed require manual staff placement. One such quirk is the very wide spacing that we have discussed when using rehearsal marks and system text. That can result in unacceptably large gaps between staves.

That was at play in this example. But the main factor is that I wished to balance page two in a way that set the coda section clearly apart from the preceding music. That isn’t a user error as you seem to be implying. it is a design choice. It was a conscious decision to place the coda as near as possible to the “To Coda” marking on the opposite page. It may not match someone’s ideal for the “artistically correct” way to do a layout, but in my experience writing well over 1000 arrangements over 40 years, it is things like this that make the music readable without error. This particular chart will be sight-read on the job. Additionally, I wanted to manage the page break where the bridge was at the beginning of page two. Likewise, I wanted to see certain system breaks in places that match the structure of the song. These little things can make a difference, giving the user an extra bit of confidence when reading a chart in a live situation. It would be wonderful if some software knew everything I was thinking, but I don’t expect that. Indeed, Dorico does a very good job of laying out the music automatically. But sometimes I need more.

If there is some clever way to do this in Dorico without manually moving staves, I would be eager to know about that, but I haven’t seen that yet.