Can anyone get RX5 to work via RX Connect in C9.5.1?

If you can please tell me how you are doing this please. The process is not working here. It works in C6.5 but not in C9.5.1. (WLE does NOT seem to work perfectly, BTW. It sends the clip into WL and back, yes, but there is still some monkey business with the returned clip as it includes not just the clip section but the entire tail of the original recording. PG is looking into it.) I have found one video where someone is using C8.1 and RX5 (and things are working) but not one using C9.5.1.

Anybody? Thanks!

I have now downloaded RX6 to see if it behaves differently and it behaves the same way. It works fine in C6.5 but does not work in 9.5.1.

Is it possible that Steinberg has opted to support WL as an external editor from Cubase and now does not support another external editor such as Izotope RX? Bummer. I will send Steinberg a note and ask them directly.

OK, I figured this out. I’ll make a Youtube video about this in the days ahead. The process is very different than it was/is in C6.5.5. The architecture of C9 is quite different here than in previous Cubase versions. The good news is that it performs properly, leaving no added tail like I am finding in the similar WL editing export and return to Cubase.

I found some info on the Nuendo 8 list, and have used a connect workaround, but it’s cumbersome and not very reliable.
I would be very interested in a working(easy) solution. I’ve also emailed Izotope tech support, they are supposed to fix this?

I’m on a PC Desktop running Win7 and 9.5.1 but you might want to take a look at my solution and my very humble video on YouTube. In my case, it turns out not to be an Izotope created problem, but the new ‘Direct Offline Processing’ process in Cubase. Let me know what you find?

Hey mr.roos,

I have the same problem with this weird Offline Processing. In Cubase 6, RX 6 Connect works very well, but in Cubase Pro 9.5.1 Trial, it’s not possible, to do any processing and it doesn’t matter, which effects I tried. There is an exclamation mark in Offline Processing window, and when not, it just doesn’t work. Don’t know, what I can do against it.
Does anybody know, if there is any possibility to use the conventional processing in Cubase Pro 9.5?


I got this working:
1.- in the offline process window, unselect autoapply (which you should disable anyway)
2.- select the region you want to edit in rx
3.-Select rx connect, and click on repair (selected by default) and click apply, rx editor will popup
4.- do your editing, leave cubase as it is, don’t close anything
5.- click send back, cubase will pop up
6.- click apply, and that’s it.

Hope this helps, it certainly works for me, I cleaned some unwanted doublebass slaps with it and worked like a charm in rx6, but i see no reason to why this wouldn’t work with rx 5

Hi rocko,

first, thank you for reply. I also use RX 6, but I also think, it’s the same procedure with RX 5 Connect.
Anyway, I solved my problem. I know, that it works this way normally, but in my case, no FX will work in Cubase. The problem was actually very simple.

You can not put your project folder in the Cubase folder, otherwise the direct offline processing doesn’t work at all. The cpr.-file may be in this folder, but not a project folder. I needed hours to find this stupid error. :slight_smile: I tried many different ways and so I was able to reproduce this error. I e-mailed it to Steinberg.
Now, it works very well.


I just watched your video. Works on my Hack too. Thanks!