Can anyone please explain why the first system's staves aren't being hidden?

I’ve set “Hide Empty Staves” to “All Systems” in Layout Options and “Allow individual staves of multi-staff instruments to be hidden” and have NOT excluded players. When viewing signposts there is nothing I see hidden. However, Dorico for some reason still refuses to hide all but the hi-hat line in the following:


Please let me know what I may be missing with thanks!

  • D.D.

Imported MusicXML file? If so:

  1. Try deleting clefs at beginning of bar 1.
  2. Check time signatures are global (e.g. select one and see if it highlights on all staves). If not, delete and re-enter.
  3. Check key signatures are global (e.g. select one and see if it highlights on all staves). If not, delete and re-enter.

Thanks! trying the above ALMOST solved it (for the first 2 staves). However, I’m still getting the treble clef of the piano NOT to disappear (despite the settings I chose, listed above, etc.):


The text there is system (not staff) text (I double-checked!) and there’s nothing else on that piano line that should be causing the staff NOT to be hidden. Any other thoughts?

  • D.D.

Is this definitely ticked, in the correct layout?

Did you select “Allow individual staves of multi-staff instruments to be hidden”?

Edit: lol gotta be faster…

Too slow, Kreider :stuck_out_tongue:

Yes - definitely selected and triple-checked it’s actually set for all staves (just to be safe). Still no dice.

Try turning on your Divisi and Staff Count signposts. Anything there?
Or you could just bypass that entirely and try changing the Piano instrument (in Setup mode) to Piano.

Oh, and that Hi-Hat text - is it definitely attached to the bottom staff?

And he did it with an image!
(Why does that sound like a lyric from Gypsy?)

We’re basically just here to bat cleanup. :laughing: That, and I’m assuming Leo sleeps on occasion. Though I’m one to talk…

Still can’t quite figure it out - I’ll have to come back to this later but for the time being getting rid of some of the staves at least made it “presentable” for this deadline (thanks all). Definitely deleting the clef and also attempting to re-do time/key signatures helped.

  • D.D.

Another thing to try is to add a new piano instrument, copy the staves to the new instrument ONE STAFF AT A TIME (not both in one go), then delete the first piano (including layouts). I’ve found that importing xml which includes piano sometimes treats the piano as two individual instruments, not as a single instrument with two staves. This might help your staff hiding issue (deleting any clef you can is hugely helpful though).

Yep, that’s what I was getting at in post #8.

Sleep? I think that’s when he’s practicing.

I wouldn’t be surprised if Leo had a library of images of all the relevant option dialogs AND gifs with solutions for all common workflow issues AND links to all helpful threads here on the forum, all available at a single key press on a macro keyboard with 12.000 keys.

Kudos, Leo! Grand Senior Member…! :slight_smile:

If only, Florian. I have a good memory and a custom Google search, and that’s it. I probably need a new hobby…