Can I edit music in parts layouts?

For example, in the parts created from my score (which is polymetric) individual parts have measures that break across staves. I would like to fix this (only in some parts, not in the full score). Another example: in one instrument, I have forced stems up or down to indicate a cross-over between two percussion instruments. In the resulting part, Dorico has changed my stem directions, rendering them meaningless.

I am used to Finale, where a part, once generated, is just another editable file, but this doesn’t appear to be true in Dorico.

Screen Shot 2022-08-23 at 4.48.11 PM

Screen Shot 2022-08-23 at 4.37.12 PM

There is a setting in Layout Options > Staves and systems > Casting off to control split bars. Since it’s a Layout Option, it can be set independently in the score and part.

Are you using a Percussion Kit? Stem direction can be controlled in the Kit definition.

Show system break signposts, and check for a purple/pink-y flag at the start of that system where bar 6 is split. If there is one, select it and press Delete. Dorico might recalculate which bars go into each surrounding system, so just be aware of that.

As Craig said above, there’s also a preference for whether to allow Dorico to create system/frame breaks in the middle of bars, or whether they should always be shunted to the barline.

Select the relevant notes (the ones with incorrect stem directions in the part) and then in the score (not the part), propagate their properties.

Changing stem directions is a local change, meaning by default it only affects the current layout when you make the change. However, if you know you want your stem direction changes to affect all layouts, change the property scope to Global before changing them – or if you’ve already changed them with the scope set to Locally, propagate after the fact.

Finale has had Linked Parts since 2007 or so, in which the parts remain within the same document as the score, and use the same music and properties.
Dorico does the same, only with a much greater level of control about what you can do separately in each layout, and what adjustments get propagated across all layouts.

I see three options under “Casting Off” (Dorico 3.5):

  • Fixed Number of Bars per System
  • Fixed Number of Systems per Frame
  • Allow Open Bars to be Split Across Frame

Checking “Fixed Number of Bars per System” and specifying a number like 4 or 5 doesn’t affect the broken measures. Same with “Fixed Number of Systems per Frame.” “Allow Open Bars to be Split Across Frame,” which looks like it could be the problem, is unchecked.

Am I missing something here?

Are you able to attach the project itself, so we can take a look at it?

That worked (meaning the part about the stems and local vs. global). Thanks.

System breaks are where I want them in the full score. There are a few case of measures breaking, but those I think are inescapable due to the number of simultaneous meters. The breaks that trouble me (like the one in the screen shot) are in the parts and do not correspond to system breaks in the full score.

Sorry, it won’t let me do that. The file is too big—7.7MB.

Can you cut it down at all?

Sometimes changing the Playback Template to Silent can reduce the size dramatically. I just tested mine: my 11.5mb file went down to 2.7

8+7(3x5) BU 2.dorico (630.6 KB)
Wow, that’s amazing. From 7.7MB to 648K.

Some notes (not particularly relevant to my problems):

  1. This is a piece for an American gamelan. Part names such as Soprano, Alto, etc., refer to instruments in that ensemble, not vocalists. You can see the instruments here:
    Other Music Ensemble: History Part 2, American Gamelan

  2. You can hear a MIDI version here: Stream 8+7 (working title) by David B Doty | Listen online for free on SoundCloud

The Casting Off could be causing a problem because any particular group of bars are from “this” rhythmic position to “this” one, and Players (like yours) don’t always have full bars ending at these positions.

For example, if you go to your Full Score and click the first four bars in the System Track, these bars are what Dorico will use when casting off four bars in every Layout - they end at “this” particular rhythmic position. Look at the Alto 1 stave and you’ll see that the four bars just happen to end on a rhythmic position that is after the first dotted-eighth note of its 6th bar.

Now, go to your Alto 1 Layout and set the Casing Off to four bars, click the bars in the System Track again. You will see the same four bars as before and cut at that same rhythmic position (after the dotted-eighth note).

Technically, it has done it’s job but don’t ask me how to fix it though!!

This definitely one for Daniel Spreadbury. If you remove the system breaks from the score, the partial bars line up with the part as it can’t align bars so it’s aligning beats. I don’t know why the part is affected like that. Seems Dorico can’t figure out any valid bar numbers due to the polymeter.

But where is the System Track getting its bar lengths? Except for the first three bars, they don’t correspond to the actual bar lines in any staff. (I haven’t unhidden all of the empty staves to see if they are a factor, but I will do so when time allows.)

I just had a look with all staves visible. For the first 16 pages of the full score the bars seem to align with the Marimba and Chimes (or is it the other way around?). Then you have changes from rehearsal mark 5.

Something was up with the time signatures on your first page – not sure how or why, but deleting the 3/8 at rehearsal mark 1 prompted an 8/8 time signature to appear. Deleting all 3/8 time signature changes on page 1 in the Soprano part and re-inputting the 3/8 at the start of the piece prompted Dorico to recalculate and system breaks fell at barlines as expected. I wonder if the fact Dorico under-the-hood understood these bars to be 8/8 was the reason it was breaking systems at apparently mid-bar positions (but would be barlines in 8/8).

Can you remember how you added time signatures to this project? No worries if not, but here’s the set of steps for inputting time signatures from the manual for reference.

I generally input time signatures by [option] clicking on the desired signature in the “used in this flow” collection in the time signature panel, after I have used the signature once.

I don’t know who Daniel Spreadbury is, but I went through the whole damned piece and changed time signatures in empty parts so they corresponded to the TS’s in other parts (mostly the alternating 7/8 and 8/8 in the tenor parts, which are the structural foundation of the piece. I thought this might force the system track to align with these measures, but no such luck. Probably good housekeeping anyway. The system track seems to have a great deal of trouble aligning with anything that is not 4/4-8/8. There are now even measures in the piece with no system track at all!

This is a symptom I’ve seen in Dorico before: the program allows you to create complex polymeters, but adequate thought has not been given to how other program features will behave in these situation and/or adequate testing has not been done by people who would actually want such features. One of the main reasons I switched from Finale to Dorico is that it was supposed to do polymeters correctly. Well, yes and no. This is only one example of the resulting headaches. I may have to manually create parts by making copies of the score and deleting all the staves but one, which will be a big pain in the arse.

I can’t help with the deleting polymeter part but if it’s urgent you could just duplicate the flow however many times, do your editing/deleting, and then assign that flow to the layouts.

Daniel Spreadbury is the Product Manager for Dorico. He has special tools available to debug problems.

It seems your file could be fixed by eliminating any global time sigs and use only local ones. I was able to do this following Lillie’s findings.