Can no longer open Dorico on iPad

I expect you’re running into a bug that we have seen with some users where Dorico is crashing when restarting and trying to reopen the project you were previously working on. We believe we’ve got to the bottom of that particular problem now, but it would be good to see whether the crashes you’ve been experiencing are one of the familiar ones.

On your iPad, go to Settings > Privacy > Analytics & Improvements > Analytics Data and find the files whose names start “Dorico” and end “.ips” with today’s date, and share them to your Mac, then zip them up and attach them here.

To get Dorico running again, the best way to do that right now is to go into the Files app, then into On My iPad, and finally into the Dorico folder, and make sure that any projects found there have been safely backed up to another location – when you delete the app, these files will be deleted, so make absolutely sure!

Then you can trash the Dorico app from your home screen, and reinstall via the App Store, and Dorico will run again.

1 Like

Just curious (not using iPad version yet): Would it also work to just move the file so the iPad doesn’t find it?

No, probably not, unfortunately.

Rebooting the iPad has previously worked for me when I encountered this issue.

I tried rebooting but it didn’t help, and I ended up reinstalling Dorico. Sorry I don’t have any crash logs to share but I’ll remember to find them if it happens again.

My hope is that the problems that could cause Dorico to crash when attempting to reopen the last project you were working on when it restarts are fixed in the new version 2.4 update, so I recommend you update to that as soon as you’re able.

in my case the trouble started with the 2.4 update. I got the black screen and unability to change back to the hub. Trashing and reinstalling the app did not help either. with Release 2.4 Dorico is not usable on my ipad pro

Dear Daniel, I found your answer in this thread, so I will jump from here
As I couldn’t open Dorico after upgrade to 2.4, only one way to run it was to delete the app and reinstall. It seamed to solve this problem, but after I couldn’t return to the hub, a made force quit. After that Dorico starts with a black screen again. So I cannot find any way to make it work. 2.3 was working fine - no crashes. Here is your requested data attached.
Dorico crash 09.07.2022.rtf.zip (6.8 KB)

Addition: I did complete reinstall for the second time today. It seams to work fine now. Any way there is sertain insecurely if it will work stabil. I am sure Dorico team will find out where a bug sits😊

1 Like

Update: Dorico restored to normal operation (delete and reinstall from App Store). Projects all accounted for (stored in Dropbox).

@jazztom, can you please try trashing the app altogether by long-pressing it on the home screen and choosing Delete App, then try reinstalling from the App Store?

Before you do it, be sure to go into the Files app, then On my iPad, then Dorico, and make sure that you have backed up any important projects that you see there.

hi Dan,
I was already succesful with this approach yesterday night. Thank You

Dan,
I have done this twice today. When I open Dorico, I get a long error about not being able to create ‘zip’ file:

There are no items in the ‘Dorico’ folder on iCloud or in the app on my iPad.
So far, I only have eight projects (saved to Dropbox). I’d like to get this resolved before I get busy creating more scores.

I’m using an iPad Pro 11 (2018) running OS 15.5.

Thanks,

Doug

We’re aware of this error message and we’re working on a solution. We’re sorry for the inconvenience caused.

Thanks for the reply, Dan!
This may help …… I can see all of my recent projects (with ‘Recent - iCloud’ selected). Problem being, that list doesn’t show the most recent version of the project. I loaded the most recent version from Dropbox and that file can not be created an shared (that’s when the error message appears). Since I can not close that project, I have to close Dorico. When I try to open Dorico again, that’s when the Black Screen happens. If I “long press” the Dorico icon, I’m presented with several project choices. I then select a different project and everything works fine (so far). It looks like the project that was stored in Dropbox is causing my issue.

Doug

Yes, that sounds right to me. Accessing files managed by third-party apps like Dropbox, Google Drive and OneDrive is even more of a minefield than accessing files in iCloud Drive. We are continuing to make good steps forward in charting a course through the minefield, but we’ll need a bit more time. I’m sorry for the inconvenience caused in the meantime.

As a workaround, I would suggest using the Files app to copy the files you want to work on from Dropbox into the On My iPad > Dorico folder. Obviously when you then edit that file in Dorico for iPad, you’ll need to manually share it or copy it back to the Dropbox location (e.g. using the Files app), but it should prevent this issue where it throws an error and gets stuck.

I didn’t expect a reply until tomorrow! You must really keep late hours.

After reading the many posts on this subject, I have been manually saving a copy to Dropbox to be sure that I have the most most up-to-date copy of the project in case Dorico needs to be reinstalled (and I upload the file from Dropbox). This is the first time the file has caused an issue. It acts completely normal until I have to change projects, try to “share” it somewhere, or exit Dorico. Would you think letting it stay open until Dorico does an auto-save to iCloud might correct the problem? It appears that it is trying to save it back to Dropbox when I try to exit.

Update (Work Around):

Using the Files app on my iPad, I copied the error/causing (and most recent) project from the Dropbox folder and pasted it into the “Dorico” folder on My iPad. I then imported the project into Dorico and everything appears to be back to normal (with my completed project.

Doug

Hi,
I ran into the same problem just trying out Dorico for iPad.
I stored a file on the iCloud and opened it from my iPad.
First error was “The file has been deleted” although it opened correctly.
Second error was the mentioned “Error creating zip file”.
In addition, no folder on iCloud was created during the installation.
Lastly, the app didn’t start anymore.
But I found a solution which worked for me:
As Daniel stated, the app tries to open a file which for some reason fails.
By pressing the app icon on the home screen longer, you can choose a specific file which can be opened. → App starts again.
To overcome the other problems, I just created a file directly on iPad and not on my PC/Mac. In this case, the app created the folder correctly (for me). Since then, all other errors disappeared and everything works as expected.
Maybe this helps someone.

3 Likes

Thanks for sharing this tip, @BrassTrout, and welcome to the forum.

Dorico black screen (wit the big D) happened to me today. I am on version 2.4.10

I tried to import a big xml file (holst planets from musescore.org downloaded in my iCloud).

After waiting 40 seconds for the import, Dorico crashed. No quit and restart (of dorico or iPad) worked. I attach in the link below the report files from my iPad how requested from Daniel.

I will try to reinstall but also hope the problem will be addressed.
Thank you.
Chris

Dorico crash analytics data

After reinstalling Dorico I tried to open the xml file. This time I copied It in my iPad folder, opened it with the attached error. (At least it opened: one step forward…) But after short time Dorico crashed and again the black screen with the big D.
I attach also the link for the (presumably corrupted file). Nevertheless is strange that the whole app doesn’t work anymore because of a bad file…
Thank you.
Error on opening

The file that causes the crash