Can no longer record any signal

Must be something very stupid and simple but cannot figure out what I do wrong.
I had reinstalled Cubase 7 elements after 4 years of no usage. Installation went flawless, VST connections are OK and when I tried to record a voice signal, the very first time it worked fine, was even amazed that I didn’t have to set up anything. I use dynamic mic that is plugged into a Tascam mk122 soundcard. When th enext day I started a new project, it was no longer possible to record a signal. I did import a mp3 backing track, that went OK and I can listen to it. The transport device shows that it detects the input signal ( I see the bar moving in the input clipping detector)
In the meantime I checked the VST connections, The record knob is turned on in the track panel, th einspector shows that the input signal is set correctly. And I still kept the track that I was able to record the very first time ( assuring me that my mic and cable and soundcard were OK )
I must have touched some knob or setting disabling the recording but cannot find what I did wrong. Help please