Can not save file, e-licenser problem


suddenly this file that I am working on won’t save. When I hit save the following error boxes shows up.

After the first try Chrome opened automatically and started opening tabs ad infinitum with the help page for Dorico.

Is there anything I can do to save my work or do I simply have to force quit and reboot?


Oh crumbs, I’m really sorry to see this has happened. I don’t think there’s anything you can do. You could try quitting Synsopos.exe manually in Task Manager and then start it up again to see if that helps, but I’m doubtful that it will, I’m afraid.

I tried but it didn’t help. Fortunately I could print the (finished!) part for the rehearsal so it was not so much harm done in this case.

Guess it’s time for me to set an alarm that goes off every five minutes to remind me to save my work!

Be sure to put your elicenser in a very secure USB socket. This message is most often caused by 1) User removing the USB elicenser before quitting or saving 2) a loose USB socket. Less frequent sources include driver failure (on Windows) or software interference with the USB driver (such as a program that wedges itself between the kernel driver and the USB device drivers).

Once this is tripped, I have not found any way to recover (though I did spend an hour or so one boring afternoon seeing if there was a way to recover from it.)

You’ve already hit on the best solution–frequent saves. I have my saves pushed through Dropbox with “pack-rat” so Dropbox also keeps a history of saves.

Daniel, I know I said it before on this forum, but I think an auto-save feature would be a really, really good idea.


Further to Traubitz’s message, I ended up with a weird loop of elicenser error messages a day or two, and I’m not even using a dongle - my Dorico license is only installed on the one computer, so it’s a soft elicense.

I didn’t think to take screenshots or pull diagnostics as I only lost a few minutes’ work, but if it happens again I’ll report with full details here.

For me, the e-licenser fails when Windows goes into sleep mode (or when it wakes up from it). Closing the lid on my Surface Pro and opening it again makes Dorico lose all unsaved work fairly regularly.

This just happened to me too. Can’t save my work (even exporting to MusicXML as a last resort gave the same error). Nothing helped and I had to re-type everything.

I’m using Dorico on a laptop, and the USB e-licenser is attached to a USB hub which I leave on my desk when I take my laptop with me. Is there a way to make the protection mechanism more forgiving (e.g. allow me to make occasional use of the software without the USB licenser connected, as long as I keep re-connecting to it every other day?)

I realize the need for software protection but having to take the USB protection with me if I leave the studio for a couple of hours seems excessive (plus I’m pretty sure I’ll lose it somewhere this way!)



If you search the forum, you will note the issues with eLicenser system have been significantly discussed. Steinberg’s position can be summed up that they are doing the best they can to balance customer convenience and piracy protection and that they are aware of customer concerns, but not to expect changes in the near term. Allusions to a hoped-for improvement in the mid-term have been made, but as to what shape any solution/improvement will come is outside of the Dorico team’s hands.

This happens to me regulary. Dorico is designed to work on a Notebook, so especially while traveling. Of course you pull out your eLicenser after starting up Dorico, so it does not get damaged. But as said, this isn’t allowed, because reasons.
Only solution: a hub in a case, where the eL is save. But this means an extra case flying around you, and if you work on a Notebook, which you are supposed to carry around, it happens, that the USB-Plug moves slightly, which will cause a “crash” (you aren’t even allowed to replug!? cause reasons?)

If you work in a studio, this doesn’t cause a problem. But I start to understand, why most of my professional colleagues who work in a creative job, prefer products that don’t require USB Dongles. The problems are known for at least 10 years now. If Steinberg is doing their best, maybe it is time to change the head department, because obviously the sub-teams (Dorico, Cubase etc.) are doing a great job in trying to create great products.

I am sorry to reopen this thread, but I lost a lot of work today and just cannot understand, why Steinberg does not seem to care about that problem at all. It cannot be said often enough, that the actual system is intolerable. I wish I could finaly drop Sibelius, but Avid and MakeMusic are without alternative when it comes to a professional environment, in which you don’t get punished all the time, for investing a big bunch of money. I am very dejected by this situation :frowning:

I’m very sorry to hear that the USB-eLicenser is causing you these kinds of problems. Please be assured that we at Steinberg certainly do care about this problem and work is underway to introduce a new, more flexible licensing system in the future.

I am very glad, to hear that! :slight_smile: Thanks for your reply!

I’m very glad to hear that a dongle-free solution is on the way. This will brighten my day!
(I like to work with my laptop while I’m lying on my back. Having something USBish sticking out of the computer in this position is like calling for disaster!)

I was wondering if there has been any progress or change on the issue of licensing Dorico so that it can be used by the same licensee on more than one machine without the need for a dongle?
Personally, I can’t use the dongle method because I know for sure that I’ll lose it in short order.

I just got this error for the first time today, and I don’t even use an USB dongle or anything. Restarting my computer fixed it. Not much work was lost thankfully, but still it’s a little odd.

I think it may have been my own fault - I had to shut down a few processes in task manager earlier, while Dorico was running, and one of them could have caused a problem with the e-licenser processes running in the background. Didn’t notice at first, because nothing seemed to have been affected and Dorico did not immediately give out any errors. It only started showing similar errors as the first poster had when trying to save the project.

Hi @tpaloj, do you remember what processes you killed? Because the VSTAudioEngine and Synsopos background processes are essential for Dorico to run. If you have killed one of the 2, you most certainly will run into such issues later on. Latest when saving the project.

Ulf, I’m almost certain it was neither of those processes. Very strange, but interconnected, networked background processes do seem to work in mysterious ways.

Okay, but even if you don’t kill those processes, watch out for them if you run into the same situation again. If they don’t run,please create a diagnostics report.