Can’t delete singular KeyCommand in Cubase 13

I noticed that if there is more than one KeyCommand assigned to a single action, there’s no way to delete one KeyCommand and leave the other in Cubase 13. It’s all or nothing. This was possible in Cubase 12.

The issue is that I want to change a KeyCommand I had added previously but still want to keep the original that comes in Cubase and uses the numeric keypad, but I don’t have a numeric keypad to reinsert that shortcut if it gets deleted. Am I missing something?

Hi, doesn’t the Reset Key Command button do the job? (The little one with an undo icon)

image

No, you are not missing something, sadly. In C13, the new redesigned key Command window show two regressions :

  • The first is the one you describe : if more than one key shortcut has been affected to a given command, there is no way, from this window, to delete key shortcuts individually. The thing acts like this, on my end (C13 pro 13.0.21 - Windows 10 Pro 22H2) :
  1. I have the Edit > Insert bar set as follows :

  1. I want to get rid of the ctrl+shift+B one. So, I click on the key shortcuts area and carefully select the key shortcut (with the semi-colon preceeding, which acts as a separator), before attempting to delete it with the relevent contextual menu command :

  1. At this point, I cannot use the Return key, otherwise, I get this kind of message :

C13_KeyCommandShortcuts3

  1. So, I click elsewhere in the window and, ta daaaa… the key shortcut is stll there.

The regression here, is that in pre-C13 versions we had a convenient key stroke list for each command that allowed us to delete one of them, if needed.

  • Additionaly, in pre-C13 versions, the Key column was redimensionable, to allow us to see all the eventual several key shortcuts affected to a given command, and this is the second regression in C13, as it’s no longer the case :

So, the only way I found to get rid of the useless key shortcuts is this one :

  1. Close Cubase
  2. Go to the preferences sub-folder (see here to know where they are exactly on your system)
  3. Locate the Key Commands.xml file and make a safe copy of it, just in case :

C13_KeyCommand_copy

  1. Open a raw text editor and make a search on the involved command (I have used Notepad++ for this). You see that there is an items list, if there is more than one key shortcut. If you only want to get rid of one key shortcut among three, in example, just delete the line of the corresponding item.

  1. Otherwise, things become more complicated. To preserve only one key shortcut, you’ll have to edit the command item to get this (here, I get rid of the key shortcuts not affected to the numpad) :

  1. Save and close the Key Command.xml file.
  2. Relaunch Cubase : you should have this for the involved command :

Couldn’t find a an easier way to do so, and we shouldn’t have to practice this kind of gymnastic to have a rather simple feature to work as expected…

Alternatively, if you don’t have a numeric pad, I think that on some laptops, there is an equivalent of the numlock key that, once unactivated can allow you to get keystrokes equivalent to the numeric pad ones, but I’m not sure. As a last resort, the purchase of a true USB numeric pad could be on your to do list…


EDIT 5 : still some typos to correct and precisisions to add, sorry…

3 Likes

There’s another regression. I still have to confirm the consistent cause, but I think it’s when you are searching in shortcut search mode, for a shortcut that is not first in the order for the command, Cubase executes the command instead of finds it.

Failing that being the always cause, then it’s random but Cubase does this very often.

Care to test to confirm?

Let me a little while, and I’ll report back here what I could have found on the subject… :slightly_smiling_face:

1 Like

OK, I have looked at this more closely I think. There has been one, and only one time when indeed, a command has been directly executed, instead of just being selected in the Key Commands window. It was this one :

At a moment, using the ctrl+alt+B key shortcut, with the Key Commands window opened, made suddenly a part of the mixer appear in the lower zone. An added ctrl+alt+B key stroke made it disappear, as expected (it’s a toggle command). The behaving was as if there was a kind of command ‘leak’.

The problem is that I haven’t been able to reproduce it, no matter if there was already a second key shortcut for a given command or with an attempt to create one. Even after closing the Key Commands window and reopening it, I haven’t been able to reproduce the issue.

More tests needed, I guess…

1 Like

Thanks for the detailed reply. I’ll check out your solution. Indeed, this is utterly ridiculous.

I had come across the search issue before the one I posted and was in the process of testing it when I wrote about the original one in this thread. I narrowed it down to using the command (Mac)/ctrl (Windows); control (Mac)/Windows key; or both, if the action is supposed to open a window. There’s a bit more. I mention it all here:

Great explanation of this key command flaw. I hope Steinberg is paying attention…

1 Like

Thanks for testing.

It is a strange one, since everyone I’ve spoken to about this is having different experiencing while confirming the ‘unsearchable shortcuts’ issue exists.

@The_Rhythmist has had a different experience to us both as well – but also confirmed some shortcuts are not findable and execute instead.

An easier work-around than editing the XML file might be:

  • select a command that does not have any key commands assigned
  • assign the desired key command to be removed from where it currently is
  • confirm the resulting prompt to re-assign that key command
  • after the key command has thus been “moved”, delete it from the just assigned command
3 Likes

Haven’t even thought about that one… :innocent:
And indeed, it works, as expected… But why make things simple as they can be complicated ? :sunglasses:

@The_Rhythmist : think that you should mark @Nico5 post as the solution for this thread.

1 Like

… because it’s “The Steinberg Way™” ? :wink:


p.s. I didn’t even think of this easier solution myself until much later yesterday – purely by coincidence – when I wanted to change an already assigned key command, that originally was part of a multi assignment.

More often than not, I find myself editing Cubase XML files like the Generic Remote or Drum Maps on a regular basis, so your post made perfect sense to me!

1 Like

Sorry, but what you said makes no sense to me. I even opened Cubase to try and “copy” the command in order to re-assign it but I can’t (I can copy and paste it but I can’t seem to make Cubase accept it. It either disregards it if I click elsewhere, and if I hit Enter it asks me if I actually want to use the Enter key as the Command).

Since I can’t copy it, how am I supposed to input it if I don’t have the required keys? (like a numeric keypad, which is the whole point of my thread, since I can always re-input commands that I can type even after deleting all the commands for a single action, the Cubase 13 way).

Have you tried to use a virtual keyboard?

Windows:

MacOS:

I’l; try to answer in my own way :

  1. select a command that doesn’t hav any key shortcut (command B). There are a lot of them, at least, on my end.
  2. select the key command that you no longer want in command A (the one which has the unwanted key shortcut - (in my example, ctrl+shift+B)
  3. You’ll get a warning message asking you if you want to assign the involved key shortcut to command B, which is already assigned to A : click on Assign.
  4. The key shortcut is no longer assign to A. You can now freely unassigned it in B.
  5. Done !

Yep. Even watched a whole tutorial on it explaining a lot of weird things it can do, but one thing it doesn’t seem to be able to do on macOS, is open a Numeric Keypad panel (I went through the options myself). While that’s a stupid move from Apple, it still means I can’t enter the command in Cubase 13 without the proper hardware. Or I’d need to download a key re-mapper software (just remembered those exist).

yeah - that maybe necessary - searching the big G this was one of the results:

If you’re saying I can literally MOVE KeyCommands WITHOUT typing the command, then HOW? Though, I don’t think that’s what you’re saying, judging from what Nico5’s responded to me just before.

To be as clear as possible, if I’m required to actually TYPE the command, then the solution doesn’t work for me. If I had a numeric keypad, I wouldn’t even have bothered making this thread and would just have chalked it up to a mindless regression that I can definitely live with, no big deal in that case, as I’d just re-type the command I want to keep.

Like I said, I even tried to copy/paste it, but after pasting, there’s no way to force Cubase to register it as a Command. If I click anywhere, it disregards it, and if I hit Enter, it asks if I want to assign the Enter key as the shortcut.

Yup, that’s the one I used (and still have) on an old Mac that has a couple broken keys. Thanks for the help @Nico5 @cubic13

1 Like

You don’t need to copy/paste anything : as soon as, for command B, you use the keystroke that you want to get rid of in A, you’ll get the warning message : simply click on Assign, and you’ll see right away the ‘dummy’ command B with the key shortcut and A, without it : then, you’ll be able to get rid of it with the ‘Reset key command’ function for the command B…