can’t get sound with headphones on macbook pro 2018

Macbook pro 2018 macos 10.14.2
I am plugging wired headphones into the headphone jack of my macbook pro.
Audio midi setup shows “external headphones” and they work fine.
In Dorico > Preferences > Play > Audio Device Setup, I see now two Built-In Audio in the driver selection.
None of them actually outputs the sound in the headphones, and Dorico only outputs audio on the mac speakers.
Any idea of how to make this work? I am travelling and this makes it very hard to work!

Hi, I am on MacBook Pro 2017 and macos 10.14.2. A setup must be similar and audio works perfectly for me. Here are some screenshots. When my headphones are unplugged, under macos audio preferences I see “internal loudspeakers”. When I plug them in, macos changes it automatically to “headphones” and I hear the sound immediately though them. In Dorico setting I see two audio outputs, but I am able to select only both of them.

Hi Florent, that is a known issue on latest macbook models and we are working on a solution.
As a workaround, you need to go to Audio Midi Setup and create an aggregated device that only includes the headphones.
Then, in Dorico go to Edit > Device Setup and choose that aggregated device as driver.

thanks! the aggregated device workaround worked!

I have the same issue, but for me (OS X Catalina, 2019 16’’ Macbook Pro , Dorico Pro when I try to switch to an aggregate device wrapping bluetooth headphones in either Device Setup or global preferences, Dorico hangs when I switch device (before the device setup dialog can be closed) and I must force quit. The aggregate device does work for output for other applications. If I use wired headphones, I can access them as outputs in the Device Control Panel accessible through Device Setup, which works fine.

Welcome to the forum, smulloni. In theory, you should no longer need to use an aggregate device, provided your headphones present appropriate input and output devices to the CoreAudio2ASIO component. Ulf might be able to help you: can you choose Help > Create Diagnostic Report and attach the zip file, called “Dorico” and saved to your Desktop, to a reply here?

Yes, please attach a diagnostics report. Also one question, do you know what sample frequencies your BT headphone supports?

I’m getting a similar problem with Dorico 3 Elements on my MacBook Pro running Catalina.
I’m not using the regular headphone jack, but a USB-C adaptor to my headphones.
Dorico routes sound to the laptop’s speakers only.
My headphones and the USB-C adaptor work fine outside of Dorico.

Hi wrldwdarr, in Dorico in the Device Setup dialog, where it now says ‘Built-in Audio’, there is to the right the little down arrow. If you click on it a pop-up list appears. In that list, does your USB-device appear, can you select it?

No, Ulf. There’s only one choice when I tap the little down arrow: “built-in audio”.

The USB-C headphone is recognized by my Mac, but not by Dorico.

Do you know at what sampling rates that USB-C headphone supports? I don’t know the exact lower limit at where Dorico works, but anything lower 44.1kHz is probably problematic.
How desperate are you getting that device going? Dorico uses a component called CoreAudio2ASIO, that mediates between ASIO and the CoreAudio system of OSX. One can enable some debug logging for it, but it is a bit tedious and needs technical savviness.

The headphone sample rate plague has returned

I don’t, sorry. But I’ve resolved my issue a different way, using the standard 3.5mm output jack, which I was initially led to believe only supported Mac-style headphones.