Can’t get the offline licenses to work. - no one answering ticket

Installing Cubase Pro 12 onto a number of stations, 1st 3 worked fine, but now I can’t get the offline licenses to work.

I select the license file, which is correctly generated from an offline license request file.
then the SAM just goes back to the previous screen.
In the logs I see
[2022-08-26 12:55:17 +01:00] [debug] qrc:/qml/main.qml:105: Current stack: OfflineActivationPage | LoginPage | LoadingPage | HomePage
[2022-08-26 12:55:17 +01:00] [debug] : GuiAppSocket received: offlineActivationRequestData
[2022-08-26 12:55:17 +01:00] [info] : respondToOfflineActivationRequestData
[2022-08-26 12:55:26 +01:00] [debug] qrc:/qml/OfflineActivationInstallForm.ui.qml:138: You chose: file:///D:/A5-stn10.smtglic
[2022-08-26 12:55:26 +01:00] [info] : Requesting Offline Activation License Installation
[2022-08-26 12:55:56 +01:00] [debug] : GuiIPCMessageTranslator sending: ping
[2022-08-26 12:56:07 +01:00] [error] : NNSocket: ERROR: 138: Timed out nn_send
[2022-08-26 12:56:41 +01:00] [debug] : GuiIPCMessageTranslator sending: ping
[2022-08-26 12:56:52 +01:00] [error] : NNSocket: ERROR: 138: Timed out nn_send

I’ve tried deleting the logs and data folders, uninstalling and re-installing the SAM (V1.4.0.843)

From the log it seems the verification of the license file is not working, because the connection to the Steinberg server is running into a timeout on the network. Check the Internet connection.

This is an OFFLINE activation.
Request generated on the offline computer, License file generated on the online computer.
File transfered to offline computer, and SAM run. Click on Offline Activation, point at license file. HANG

I know, I can see it in the log. But the log shows some entries that point to a network connection.

On the other hand, you say that you already have three licenses activated, so this would be number four and that is, according to the license, not allowed. At least not with a single Cubase license.

Sorry I wasn’t clear…
This is not registered against the same license. We have 21 license keys registered, and this machine is activated on a license key by itself.

I believe that the network connection you can see is not one to the internet, it’s IPC (interprocess communication)
SAM is meant to talk to License Engine. On a few machines that has worked fine. A few days later I try doing some of the others and run into this issue.

Ok, in that case the actication should simply work as usual. I don’t know how the internal workflow of the Activation Manager works, so yes, it is probably trying to create IPC sockets.

Here I recommend to call the Steinberg Hotline and not wait for the ticket, they are the best help in fixing this problem. I’m not sure if someone in the forum knows these internals.

Sorry for not being more helpful

1 Like

Here’s another post (from the Dorico forum) with similar but not identical circumstances. The NNSocket Error 138 timeout is the same, however.
Have a look at the second last post which suggests a procedure to resolve this.