Can’t monitor thru Amplitube, with 0 latency, Plugin grayed out.

Please help me dear friends,
I can’t monitor thru Amplitube 4 when “constrain delay compensation” is on.
I tried asio guard on and off and tried different combinations but amplitube 4 is still grayed out.

Of course if I turn off constrain delay compensation than amplitube 4 becomes active but with latency which makes it impossible to play or record.

I tried disabling all the oversampling options in amplitube too make it less cpu heavy but still no luck.

What settings can I try to change to be able to monitor thru amplitube 4 with minimal latency ?

Well yes. That’s the whole point of CDC. Don’t use it if it isn’t appropriate for your situation. Turn down your buffer size to the latency you desire. Use asio guard to minimize the cpu load. It is quite common to use Amplitube as an insert on a monitored track.

But, Without cdc I can’t turn buffer too low without getting drop outs.

So neither options work.

I actually tried amplitube in an empty project with just one track and amplitube being the only plugin, still with cdc cubase couldn’t activate the plugin

tried amplitube in Presonus Studio One 4, using that “Z” dual latency mode,
and amplitube works fine without any noticeable latency.
I’m really confused now. Why can’t this work in cubase 10 which is much more advanced than presonus studio one ??

What is the threshold for CDC set to?

Raise the “Delay Compensation Threshold” value.

Constrain Delay Compensation
https://steinberg.help/cubase_pro/v10/en/cubase_nuendo/topics/vst_instruments/vst_instruments_constrain_delay_compensation_c.html
Preferences>VST>Delay Compensation Threshold (for Recording)
https://steinberg.help/cubase_pro/v10/en/cubase_nuendo/topics/preferences/preferences_vst_r.html
Studio One’s threshold value is 3ms. So plugins with less than 3ms latency are not deactivated by low latency monitoring mode.


Details on ASIO-Guard in Cubase and Nuendo
https://helpcenter.steinberg.de/hc/en-us/articles/206103564-Details-on-ASIO-Guard-in-Cubase-and-Nuendo

Audio Mixdown, Freezing and Render in Place can be accelerated by increasing latency. This might reduce the resolution of automation though. VST 2 plug-ins calculate one automation value per parameter for each ASIO block (which equals buffer size in samples).

Because of this, large buffer isn’t good solution. ASIO-Guard is pre-calculation, so the resolution of automation is not affected.

oops I didn’t know you can set threshold for cdc in cubase, will try it soon today

Ok I changed cdc threshold to .3ms,
now Amplitube works in cdc mode