Can you speed up loading channels/VST effects? Why so slow?

Hello,

It just occurred to me that when you have many VST effects on the project, Cubase loads FOREVER. I mean, 30 seconds or more for instance…BUT:

During that entire load time, it uses hardly ANY machine resources. I mean, the CPU stays at under 10% so clearly it’s not doing any work, the disks output next to nothing, memory load is neglible…so WHAT does it actually DO when it says loading project, then loading channels etc…?`

Is there something that could be done, perhaps on software side, to improve that behavior so it’d actually employ some of the DAW’s resources to speed up the process? What am I maybe missing here?

It really seems that it’s just as slow a process regardless of machine speed. Doesn’t take much longer to open such a project on a 2 core ancient slow junker …and I believe it would take the same time on any machine almost regardless of speed.

Vst effects are clearly the reason behind it, for whatever reason it takes ages to arrange them.

https://youtu.be/TOo6qeJULEA

If you only ever use plugins from known safe sources (ie not “freeware” off the internet) then you can exclude the Cubase and VST folders from your antivirus checking, this means the hundreds of modules loaded when you load a project do not have to be scanned. This will also greatly speed up the twice yearly VST scan when the clocks move forward/backwards.

Some have had luck speeding up their startup time by adding the Steinberg folder (where the Cubase.exe is) to their antivirus exception list. Maybe adding folders where your VSTs are located would help too.

Also, applicable if you have a nVidia graphics card… I did follow a suggestion I seen in a recent post around here (can’t seem to find it though) that explained how to add Cubase to your nVidia graphics card and set it as a program to run with your graphics card in full performance mode. After I applied that suggestion my Cubase runs generally faster. Even the startup time. Might be worth a look.

Regardless, here is what I did:

  • Open the nvidia Control panel
  • Click on the “Manage 3D Settings”
  • Click on the “Program Settings” tab
  • Check in the drop down to see if your Cubase XX.exe file is one that is listed. If not, add it to the list.
  • Click on the “Power Management Mode” and set it to “Prefer Maximum Performance”

Again, changing that one setting definitely helped with CB audio and general speed increase.

Give them a shot. You can always reverse these suggestions if they don’t improve things.

Good luck.

Regards :sunglasses:

I was a bit skeptical about that, but it actually works.

I must be doing something in my projects that makes them very slow to load.

I just created a 32 track project, loaded wav files and tested it plays fine, made a few adjustments.

Loading it again takes much less than a second.

Then I added an fx buss with Abbey Road, and some compression on a bunch of tracks, volume automation, master effects like Ozone 8, Maserati, and did random crossfades and copies and changed levels.

Still loads the project in about 4 seconds.

I duplicated the tracks six times so now I have like a hundred VST instances and over a hundred tracks…project loads in about 7 seconds now.

I imported over 700 wav files for nearly a thousand tracks, that took 20 seconds or so, and randomly mixed those around and did cuts and whatnot…

The project loads in about 14 seconds and in playback uses only about 25% of machine resources. With a thousand tracks!

Then when I load my small project it again takes nearly 50 seconds to load. WTF?

I must have some VST there that slows it down greatly or am doing some sort of edit or something that makes it so slow…

But even if I disable vst effects or remove the fx tracks and so on…still just as slow to load.

I’m going crazy with this thing…