Cannot activate Cubase 7

I had to reformat my drive due to windows issues. I reinstalled my Cubase 7 upgrade (I’ve been purchasing cubase since Cubase SX). Now when I tried to activate it I cannot it is telling me there is no valid Cubase version to upgrade from. I tried using my activation numbers from Cubase 4, 5, 6 and 6.5 and I’m getting the same messages. I threw out my Cubase SX box ages ago not thinking I would need the activation code again. Do I need that activation code? Am I screwed now? shouldn’t my licenses still be on my licenser, and why did they dissapear if so??? I have sessions to work on and I’m completely freaking out now.

Now I also find out that Steinberg no longer has phone support??? That’s absolutely ridiculous. This email crap is for the birds, I ned help NOW with the product I purchased (and have been purchasing for years since Cubase VST/5 and before that). So no phone support is totally unacceptable.

Can any forum users help me out here, since Steinberg tech support seems to have become half assed? Thanks!

No need to activate more than once. If eLCC reports the license is C7, you’re done.

No, I installed Cubase 7 and tried openeing it and get the message “no valid license found the program will quit now”.

So I figured I guess I need to reactivate it again on my licesner opened up my cubase 7 upgrade box tried to activate and was told there was no previous version of Cubase 7 to upgrade from. So I figured well I guess I need to try my 6.5 activation code, same message, went to my Cubase 6 code same message kept going back to the version I still actually have in a box, Cubase 4, same message. I cannot open Cubase 7, the licesnse has dissapeared from my elicesner and it will not activate and license again.

Make sure the Dongle isn’t in a USB3 port. Update to latest eLCC.

I haven’t taken the dongle out of the same USB port I’ve ben using it in for the past year and a half.

Latest version of E licenser installed also.

I moved the dongle to a different USB port and it now works. Oh jesus I was freaking out. Thanks man!!!

Steinberg still neds to get back phone support. Thats just ridiculous.

Just out of interest, will a program like CCleaner repair problems like this?
When a USB port just stops working with a specific driver, will it remove the driver instance from this port in the registry if it’s not being used ?

No I don’t believe CCleaner will do this.

Just as a sidenote… messin’ with any ‘registry tools’ when you are not sure how they work is asking for a ‘major’ problem.

Better left alone.

Wise Registry Cleaner fixes problems without causing issues (German made too :wink:

Long long time ago (B4 XP) I used to fix this problem manually in the registry (used to happen with drivers more often), but it was indeed not easy involving those long coded strings. I wouldn’t try it any more, as I’m no longer in that kind of headspace and you’re right, messing with the registry is asking for trouble, which is why I wondered if Ccleaner could do it - I know it can be done, just wondering if there was a tool that could do it, cause it’s a pain when it happens.

There is a tool called Wise Registry Cleaner, free of course and German made also.

There’s another one made in South Korea called iobit advanced systemcare and both seem to be based on the same codebase but I much prefer the german one as there are no ad’s.

Basically when I have a problem, say the system won’t go on standby or shutdown, or my 4G usb modem freaks out or a longer than ususal boot and/or power off I gauge a program by how well it can address the situation.

In other words if it stops me having to re-install my OS, it may be even worth paying for (or at least recommending to others).

I uninstalled all the iobit systemcare software on one of my PCs - i find their marketing a bit too aggressive. When I looked at Wise I thought it was very similar to Ccleaner.