Cannot Burn ISRC codes

I’m new to Wavelab 8 being a long time Peak user so please excuse any my initial lack of expertise, I’m learning.
Mastering Computer: MacPro Quad 2.66 16 Gig Ram All SSD. Apogee Rosetta 200/Symphony PCIe64 interface.
Okay: Don’t have any trouble with any mastering functions of WL or creating and editing within the Montage, CD text and addition of ISRC codes etc seem very straight forward and relatively easy to input.
The trouble is when I burn my CD’s or DDP images I see the metadata text in my text reader (Mac Terminal Utility) but not the ISRC codes after a burn. I checked my CDR drive with five other CD’s and codes are there with Mac Terminal utility. Is it possible that I have left something unchecked before my burn, some small parameter that I have not acknowledged. I can’t seem to find anything in the user manual that I haven’t already addressed but I find the manual pretty bewildering to be honest.
Any help would be greatly appreciated.

I don’t know what Mac utility you are using to check this, maybe the problem is there.
Simply import the DDP in WaveLab, or the burn CD: do you see the ISRC or not?

As far as an ISRC is entered, it should be burnt in WaveLab. There is no extra option to activate.

Many thanks for the the reply Phillipe,

I have not tried importing the the burnt CD “back” into WLab but will today.
My concern is that I’ve always been able to see all metadata including ISRC’s in the Mac utility I’ve used for years,I can see everything except ISRC’s burnt on the CD from WLab.
Will advise.


I can add to this…I have never been able to retrieve ISRC’s when re-importing a CD burnt with WL. That hasn’t been working since version 7 for me.

You have to explicitly retrieve isrc codes.
Secondly, it is not uncommon to have a drive that has a buggy firmware to retrieve isrc codes.
I think the wavelab function works correctly, with a valid drive.

Good news…I “can” see the ISRC’s after importing a CD burnt in WLab:))))) ergo those data are being written which is a relief, I’m still baffled as to why I can’t see it all in my old Mac Utility.
However I have not heard back from my duplicator as yet to whether or not they see the codes when written to a DDPi from WL then uploaded, will advise.

What I still find a bit odd is that I still don’t see the codes in the ISRC pane of the import CD window but all the song titles are there, it would be nice if you could (is that a Mac issue?) However as Phillipe says you have to specify “what” exactly is to be imported in both master panes of the import window, once done and import is complete Voila!!! the codes are there.

I realize that we Mac users are newbies to WL in reality so make sure that you have the correct type of file selected for your import and that stream is correct. I OVERLOOKED NOT SELECTING Mac AIFF ON MY IMPORT WHICH IS A CRITICAL MISTAKE. I have not tried burning a master mp3 file yet with the codes and reimporting that but will and advise.

Thank you for your patience and suggestions this is great Forum and considering it’s moderated by the designer makes it even better. WLab is very cool, I couldn’t imagine ever going back the Peak even if it were still available.


AFAIK, it has always been like that in Windows as well: ISRC codes have to be separately requested. Don’t know why…

In the Audio CD Import dialog check:
tab “Functions”> “Extract ISRC codes”
if you need this info permanent check “Options” tab

works on my old MBP OSX 10.6.8 and WL 8.02

regards S-EH

AFAIK, it has always been like that in Windows as well: ISRC codes have to be separately requested. Don’t know why…

Because retrieving ISRC codes can take a longgggggg time, when there are many tracks. And this depends too on the firmware quality. Hence the option is better off by default.

Ah, good decision then. And something new learned for me.