Cannot export mono mp3 file

Don’t know if this has been reported yet - haven’t seen it addressed.

I am working with mono files in the Wave Editor. If I export them as mp3 - using ANY settings or either encoder - they are converted to a stereo mp3 file with severe interchannel echo. Cannot export a mono mp3 file from a mono audio project.

BTW - I tried exporting a stereo file as mono and that DOES work. It will not export a mono project as a mono file.

No problem here. For instance, a quick test is ok with these settings:
2013-07-14_07-12-57.png

PG,

Here are the settings I used.
Wavelabe mono export.jpg
The rendered file is stereo and the audio is only on the left channel with noise on the right. Other settings I tried also produced a stereo file even when I selected to output only one channel or a mono mix. In those cases the rendered file was dual mono with an echo between left/right.
mono export.mp3 (1.32 MB)

The Lame menu allows you to choose mono or stereo output. I guess you selected stereo. Here with “mono” selected, this works fine. Please try again.

PG,

Good - yes, the Lame encoder set to “mono” works - will use this. Thank you for pointing that out.

The Fraunhofer encoder, however, does not seem to work with mono files. Attached file was exported using preset “Mp3 FH 128k cbr”.
FH 128.mp3 (165 KB)
Even though “match input stream” was selected the rendered file is stereo with audio only on the left channel.

No problem here with FH.
I am curious to know how you obtain this mp3 file.
Are you using WaveLab 8.0.2?

PG - you know the answe

PG - you know the answer to that question from my PMs. :blush: No, I’m using 8.0.0 right off the disc. Regardless, I don’t see any mp3 export issues addressed in either the 8.0.1 or 8.0.2 fix lists.

How I obtained the export was by selecting the “Mp3 FH 128k cbr” preset and exporting. Have you tried exporting a MONO audio track using this encoder? I would expect either a mono mp3 or a stereo mp3 with duplicate channels. What I posted above is what I got - audio on the left, noise,nothing or echo on the right.

Is it possible something is corrupt in my system having tried to install 8.0.2 unsuccessfully (I’m on WinXP)?

Fender19, I don’t think you’re going to get much help with anything here using XP, which is as it should be, but to answer your question, I’ve rendered from a mono file using the same FH preset on XP with 8.0.1 and it works fine. The MP3 created is a mono file. And I too unsuccessfully attempted to install 8.0.2, so I doubt that’s it. You could try a complete uninstall/reinstall, and update your elicenser software like I did. Or get a copy of 8.0.1 if you can. Or update to Win 7 if you can.

Do you know where I can get 8.0.1? It’s no longer linked to the “8.0.1 released” sticky above.

Win7 is in the works unfortunately it is no small task on my system to do that “upgrade”.

Understand. But v8.0.0 and 8.0.1 are compatible with XP and not a lot of people work with mono files so I thought there was a hidden issue here. Everything else seems to work OK including the LAME encoder. Guess it is just on my end. Will try to figure out why, reinstall, etc. Thanks for your feedback.

I work with mono files - daily in WL. No issues whatsoever with creating mono MP3. I - however - never use the Fraun codec nor Windows XP.

LAME all the way here on Windows 7.

VP

Have you tried the “Fraun” codec with mono files? Please do and tell us if it works for you.

Just tried it with a session file from a day or two ago. No problems at all. I simply changed the codec in my Batch Converter from LAME to Fraun…

Resulting file is 128kbps mono

Cheers,

VP

OK, it works here too - except “Media Info” is telling me the mp3 is a “2 channel” file. It sounds mono because it is two channels of the same audio but it is a STEREO mp3 file.

If your mp3 is a mono file (and not just sounds mono) why are we getting different results?

BTW - When I export a mono file using the LAME mono settings Media Info is reporting it as a mono mp3 file.

Fender19, sorry this still seems to be consistent problem for you. I’ve tried to recreate your FH problem but can’t on multiple systems. The one thing that did occur to me was the source files you’re using. Are they all created by one program? Maybe you could try creating a test file in Wavelab (Signal Generator or DTMF Generator) and rendering from that. And maybe having both files on the desktop, or some path different from what you currently have.

Hey Fender 19,
You mentioned “Media Info” is telling me the mp3 is a “2 channel” file. " And i have a couple questions for you that my help… (or not…)

Where are you getting this media info?
Is it possible that it is cached and is not updating? For example if the first time you tried to make the file and it created it as a stereo or 2 channel mp3, is it possible that your current version actually is a mono single channel file but the media info is getting updated?

I’ve used snapper alot and this often happens. So possible you need to clear a cache or simply try a new file with a new name to confirm this.

Just a thought, hope it helps.

“Media Info” is a program that reads the header of media files and displays the sample rate, number of channels, etc. I have found it to be quite reliable. http://mediaarea.net/en/MediaInfo

Also, when I load this mp3 back into Wavelab it shows up as a stereo track/waveform display.

But, as you say, there might be something tangled up somewhere in my installation. I run many other audio apps, video editors, etc., so who knows …

The source file was not created in Wavelab but it does show up as a mono file in the waveform editor.

I will try your suggestion. Thank you.

BTW - what happens if you attempt to load a stereo file into a mono project? Does it appear mono when it is in fact still stereo - or does Wavelab strip off one of the channels - or will Wavelab report the mismatch and not load it?

Conversely, what happens if you try to load a mono file into a stereo project? Is it still mono or does Wavelab create a duplicate track in stereo, etc.?

In other words, is it possible that what I am seeing on the WL display is NOT the actual track count of the file?

Hmmmm … I need to investigate that. Maybe, as you suggest, my problem is at the source. Will check and report back.

I will check my resulting “Fraun” MP3 back into WL later tonight and get back to this thread…

VP