Cannot find VST3 plugin

Good morning. I just installed Surge XT 1.2.3 but not matter what I do it does not show up on the list of available VSTs. I restarted Dorico multiple time. I’m using Doric pro 4.3.30.1132 on Mac OS Big Sur 11.6. Attached is a log.
Dorico Diagnostics.zip (409.6 KB)

1 Like

Clear the audio engine cache and rescan perhaps? [Funny, second post on a VST not appearing in less than 5 minutes. Coincidence.]

Make sure it is installed in the canonical path for VST 3 plugins, which is a fixed location. See here:

According to the audio engine logs in your diagnostics, the Surge XT plug-in has been block-listed on your system. I’m not sure why – perhaps @Ulf will have some ideas.

Hi @fiboribo , please run the attached shell script and post back the corresponding output file.
First unzip the file and then drag and drop it into a Terminal window.
If you have trouble or need more detailed explanation, please don’t hesitate to ask.
scanVSTs.zip (846 Bytes)

I see. I ran the Surge installer again and it works fine. The Surge team is trying to help me get Surge XT to play microtones natively in Dorico. I was sent a replacement VST3 file to try but it apparently still needs some work. If anyone is interested in how this develops we have an ongoing discussion about it in the Tuning channel of the Surge Discord server.
Thanks for your help!

1 Like

Ok we are testing a new version of Surge but are having the same problem. Is there a way to remove un-block-list a VST manually? The only two options I see are “clear audio engine cache” and “reset audio engine data.”

Clear audio engine cache should do the job, whereas a reset really sets everything back to default

Hi @fiboribo , you (or maybe someone else) marked your own posting as the solution. Is your problem now really solved?

1 Like

No I did not, but the issue may just be on the Surge end of things. The development team is working on a solution. I’ll post an update here when I have it.

Thanks for checking in.

1 Like

Today I’ve installed the AudioChiper plugin. Despite the fact it works in Standalone mode, there’s no way i can find it in my Cubase Elements 10.5. Any idea how to solve the issue? I tried to install/uninstall/reinstall all while restarting etc,… please help. Thank you.

Hi.

This is the Dorico forum. I think you want the Cubase forum!

Sorry i’m blonde,… just joined,… will pay more attention in the future.
Thank you!