Cannot monitor midi instruments input

It’s a bit of a weird thing…
Basically I’ve been doing audio only recordings for a few months and haven’t had to use any midi instruments tracks since upgrading 7 > 7.5 but now I’ve been asked to write some music for a film.
I’ve added some instrument tracks (halion & kontackt) and can make sounds appear from the keyboards in the plugins.
But I can’t hear what I’ trying to play in.
The midi input monitor responds, the track input monitor is on and the midi input channel on each track is set to ‘any’.
If I open the key editor and record something in, the notes appear, but I don’t hear them until the section loops around and plays it back.
Am I just doing something daft or is there some setting I’m missing?..
Should I just try trashing the preferences file?
This is on windows7x64

Thanks,
Sean

1 Like

Hi you,

is the Little brownish “Monitor” button pressed?
Is midi through enabled in the program Settings?

Cheers, ernst

Yes. both of those are on. Which is what makes it weird!
Notes will come in (but not reach the VSTi), notes will go out, but not at the same time.

Have you checked the output area in the track to make sure that the correct VST path is chosen? And MIDI channel?

Also, both HALion & Kontakt feature multiple outputs. Have a look at those.

Finally, I sometimes accidently slide the Mod Wheel down on my keyboard, which can lower the volume on Kontakt’s instruments[s] to almost nothing.

As always, double-check the obvious before deleting anything [or pulling any hair out]. :unamused:

have you clicked the big red “arm record” button on the midi track? common oversight for users new to cubase

:wink:
cheers

Having been using Cubase since the early Atari days (actually since the end of Pro24), I’m aware of the record arm buttons… :wink:

It was in fact…
The midi filter.

I found a VSTi midi monitor and that showed me that aftertouch was getting to the channels, but note data wasn’t.
That led me to the preferences -> midi -> midi filter -> untick the ‘note’ boxes.

Which means I’d turned that on when recording an electronic drum kit with a band for an EP (for using the in-built sounds directly as opposed to listening via midi because of the inherent latency) but forgotten to disable it again given that all intervening projects have been audio only…

Thanks for being there :slight_smile:

I have the same problem in Cubase Elements 10 and Elements 11: MIDI Input works, I can record the notes, and they play back in the instruments, but while recording or just monitoring the track, I do not hear anything. For instruments that come with a virtual keyboard, I can play it with the mouse and I hear the sound.