Cannot open Cubase 8 files in Cubase 7.5?!

I wanted to test my CPU usage in a current project with Cubase 8 vs 7.5 and I got the error “This file was created in Cubase 8.0.3. This program version cannot load it.”

I thought all cubase projects were backwards compatible? At least I think I remember opening Cubase 7 projects in 6. I believe I even opened Cubase 8 files in Cubase 7.5. This was one of the things I loved about cubase, as coming from Logic I was never able to do this.

Did things change with this update? Very sad right now. :frowning:

edit: I just tested loading a different project I made in Cubase 8.0.2 and it loads fine in Cubase 7.5! Any ideas on whats going wrong with this project? Is this something new with Cubase 8.0.3?

Not sure what’s going on. Because of the retrospective record problem (yeah, Steinberg, this is aimed towards you) I’ve been having in C8, I’ve been using 7.5.20 and projects I worked on in 8.0.30 have been opening fine. Have you tried copying your prefs from your C8 folder into your C7.5 folder? Of course, backup your C7.5 prefs first.