Cannot record midi

Every time I try to record anything with my midi keyboard either it just records one note or nothing at all. The peculiar part is that I can play with my keyboard without any issues when I am not recording. It only happens when I hit record.

Welcome to the forums.

Are you able to draw in notes with the pencil tool or with the step record mode? What recording mode are you using?

The pencil tool works just fine. I have tried using a different midi interface and it does not work. I am using the “regular” record mode. I have tried monitoring the midi signal and it seems to “disappear” when I hit record. And only when I record.

Which interface do you use? And, may I suggest you put some information about your system in your signature. I’ve never had a problem like this, however, often, doing a reset of your preferences will resolve issues. You may want to try that.

Can you monitor the midi output and only not record? Re-check all your device setup settings. It should work.