Cannot reformat WAV files

When I load a WAV file in Spectralayers 8 Pro, the Project->Reformat menu option is grayed out. If I load an AAC file, it is available.

Because of this, I am not able to resample a WAV file in Spectralayers.

Doesn’t happen with me. Load a .wav file in SL, and reformat is available.

So far I’ve tried 96K 32-bit, 48K 24-bit, and 48K 16-bit WAVs. Reformat is grayed out in all three cases.

This is on 8.0.10, on Mac.

Ah. I’m using SL8 on a Windows 10 PC. That might be key.

@Teilo Does this happen if you open your file through File > Open ?
Can you do a screenshot of the whole interface, and showing Reformat being disabled ?

Huh. It works fine if I use File, Open…

That’s a weird bug.

Here’s a screenshot when opening with a right-click from Finder.

And here’s the same file with File, Open…

I see. It’s actually an intended behavior, but I should add an exception here.
When SpectraLayers receives a file from an external application (such as Pro Tools), it freezes the format so when that file returns back to the calling application the format is still the same.
The unwanted side effect here is that the Finder is also considered an external application sending a file to SpectraLayers. I’ll add a check to avoid this issue.